-   Linux - General (
-   -   Loading modules in Gentoo results in "Unknown symbol module_refcount" (

Spooled 05-20-2006 10:55 PM

Loading modules in Gentoo results in "Unknown symbol module_refcount"
Hi everyone.
I've just installed Gentoo and have come across issues when setting up Samba and setting up the fglrx module for my ATI Radeon x700 PCI express card.
When I "modprobe fglrx" and "modprobe smbfs" both error and dmesg says:
"Unknown symbol module_refcount" for both.
I've tried every suggestion that I have found but to no avail.

I do have module unloading enabled in the kernel.
I've also enabled everything in the kernel that the ATI FAQ pages say to do, as well as samba.

I've emerged ati-drivers and samba.

Is there something that I'm missing? is there a way to make these(and other) modules find the module_refcount function?

BTW: Distro is Gentoo kernel 2.6.16-gentoo-r7.


Centinul 05-21-2006 04:39 PM

Just out of curiousity have you run "etc-update" after syncing and updating your software? I ran into an issue once and updating the config files with etc-update fixed it. Just a long shot, hope this helps.

Spooled 05-21-2006 05:42 PM

When running etc-update, the config files that need updating don't appear to have anything to do with this issue.
(At least it looks that way to me)
Thanks for the suggestion. I need all the help I can get!

Spooled 05-22-2006 04:20 AM

Solved It!
I noticed that the 2.6.16-r8 kernel was out. Figured it was my last hope so I gave it a try and it worked!
Not only did it solve the samba problem, but the ATI drivers also work now(and that really suprised me since the ATI drivers are a pain)
Lucky me I guess.

Centinul 05-22-2006 05:48 AM

Awesome! Enjoy using Gentoo, I dived into it about 10 months ago and haven't looked back since :)

P.S. ALWAYS run etc-update after you sync and update your packages. The config files may not appear to have something to do with your problem, but you never know. :)

All times are GMT -5. The time now is 02:43 AM.