-   Linux - General (
-   -   Linux "mem=" commands (XBox xDSL) (

Thraxen 09-12-2006 11:34 PM

Linux "mem=" commands (XBox xDSL)
Hey all,

I've been running a program (LinMugen) on the Xbox that runs on a version of xDSL. It runs pretty good, but does need a bit more memory. My Xbox has 128 MB of RAM as opposed to the standard 64 MB, but Linux doesn't recognize it. When it boots, during the hardware detection, it says "64 MB RAM with 4 MB Frame Buffer" on the screen. This is correct for a standard XBox. But I would like to have it use all 128 MB.

I've done a bit of research on the internet and found some different commands to try, but so far none of them have been successful. Here are a few of the commands I have tried and the results (these were added to the append line in the boot cfg file):

mem=124M: No change (still said "64 MB RAM with 4 MB Frame Buffer")
mem=64M@64M: No boot (crash - blank screen)

mem=60M@64M: This one showed promise. It said "128 MB RAM with 4 MB Frame Buffer" while booting, but then it crashed. After the crash it said a whole bunch of stuff. At the top it said "Oops: 002". Then it had a whole bunch of hex in a section labeled "Call Trace". And at the bottom is said something about "Kernel Panic" and "Interrupt Handler". I can be more specific is need be, I just didn't write any of that down when it happened.

I also tried this:
mem=124M video=xbox:480p:fb_mem=4M@124M

That resulted in a kernel panic too, but I can't recall if it said 64 MB or 128 MB RAM during the hardware detection.

Anyway, anything else I could try? You'll have to excuse the fact that I know very little about Linux.


All times are GMT -5. The time now is 07:29 PM.