-   Linux - General (
-   -   linux keyboard layout problem (

golden_boy615 02-22-2010 01:03 AM

linux keyboard layout problem
Hello every body
I add a keybord layout to my linux except US language and add keyboard layout switching key . first of all why this key switching does not work in most linux distribution (fedora 8) and super ubuntu 8.04 and ubuntu 9.10 then when linux goes to stand by and locked the keyboard layout goes to it's second (non english) layout that I can not change it to entering my password in english to login. how does it work or how can i fix it. I have this problem on fedora ubuntu and debian.

Thanks for any help.

raju.mopidevi 02-23-2010 10:00 AM

I am using openSuSE, i don't face such problem. I can easily switch between US keyboard and my local lang keyboard.
Tell us how you added keyboard layout. how you are switching ? are you using SCIM ?

gookank 02-23-2010 02:21 PM

I found this on ArchWiki :

You can edit xorg.conf

To change the keyboard layout, use the XkbLayout option in the keyboard InputDevice section. For example, if you have a keyboard with English layout:

Option "XkbLayout" "us, se"
Option "XkbOptions" "grp:caps_toggle"

This makes your Caps Lock key switch between the different layouts. This is mainly useful if you do not run a Desktop Environment which takes care of keyboard layouts for you.

I also use "setxkbmap en" or "setxkbmap tr" to change the keyboard layout.(en is for english, tr is for turkish... list of keyboard layouts :/usr/share/X11/xkb/rules/xorg.lst)
If you are using KDE or Gnome it is much simpler and you can have an applet near the clock for this purpose. I also experienced that in KDE4 you can assign key combination to switch keyboard layout. For example you can assign windows-key for this operation. it is very useful when you only need to switch to the second layout temporarily. It is like a shift key.

All times are GMT -5. The time now is 10:23 AM.