LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 07-12-2002, 01:08 PM   #31
joeprogrammer
LQ Newbie
 
Registered: Jul 2002
Location: Gulf Coast
Distribution: RedHat, Mandrake, Debian
Posts: 3

Rep: Reputation: 0

If you have another PC laying around, configure it with just the services needed. If the problem goes away, then you know it's something in the current box. Otherwise, look for I/O problems like hard drive or controller. Wild speculation - It could even be a BIOS or other motherboard problem. Try loading Linux on the NT box and see if it cruises as well as NT did. Or - load NT on the slow Linux box and see what you get!
 
Old 07-12-2002, 03:11 PM   #32
bdp
Member
 
Registered: Apr 2002
Distribution: RH 9
Posts: 230

Rep: Reputation: 30
if you continue to use x, unclicking 'use nautilus to draw desktop' in the window options of nautilus might recover another ~50MB RAM.
 
Old 07-12-2002, 03:26 PM   #33
shoot2kill
Member
 
Registered: Jan 2002
Location: California
Distribution: Red Hat
Posts: 402

Rep: Reputation: 30
If you continue to read the thread properly, it was due some months ago.
 
Old 04-19-2003, 06:01 PM   #34
coldascold
LQ Newbie
 
Registered: Jan 2003
Location: Tasmania,Australia
Distribution: Debian
Posts: 21

Rep: Reputation: 0
You have a full on mulit-threading problem.
I had the same Problem on a Busy LAN with an AMD 1200mhz , 720 SDRAM,IDE disk machine.

Ya I am talking a Busy LAN that uses its Server,for all purposes.
The poor thing would barly do anything in a Graphical sense or multiple disk transfers .Same happened to Win 2000 in the same position, Browsers were very slow to open on the server although you should never use a server for this purpose.

Upon getting a cheap NetServer 133mhz with 64 RAM and 10,000 RPM SCSI disks the Problem went away totally although the machine was never able to run X windows So could not be tested to the full extent,however multiple transfers from the disks were improved 100% in speed and the rest.

You need a Server Mr. Linus
 
Old 04-19-2003, 09:00 PM   #35
Whitehat
Senior Member
 
Registered: Feb 2003
Location: The Cold North
Distribution: SuSE 9.1
Posts: 1,289

Rep: Reputation: 46
Yo,

I am not trying to be mean at all......but....

I see absolutely NO reason to use a window manager with a linux server. I would have that box loaded minimally with like RH 7.3 with command line only. Like 700 MB's loaded. Or Slackware with a minimal load too.

You can do everything with command line

For what you are doing you should be able to get away with a PIII500, 512MB RAM, and just command line. Heck 256MB would probably be just fine.

WM's hog memory and so do nice pretty fancy GUI apps...

Peace out...
 
Old 04-20-2003, 03:05 AM   #36
Mork
Member
 
Registered: Mar 2003
Location: Visby, Sweden
Distribution: Ubuntu 4.10
Posts: 64

Rep: Reputation: 15
Have you checked if DMA is activated. In some distros it defaults to off. I run a box for a while without having it activated and got all sorts of freeze-ups while moving lots of files (on a Pentium IV 2,4 GHz).

Use hdparm to check if its enabled and toggle it on and off. I don't have the exact command since I'm sitting at a windows box at the moment, man hdparm should give you the answer.
 
Old 04-20-2003, 04:57 AM   #37
plisken
Member
 
Registered: Dec 2001
Location: Scotland
Distribution: Slackware 9.1-15 RH 6.2/7, RHEL 6.5 SuSE 8.2/11.1, Debian 10.5
Posts: 516

Rep: Reputation: 32
Similar situation

I have been running a RH7 server, providing FTP, http and also file serving to at most two other machines(Win*).

This machine sis equiped as follows:

AMD Athlon 800MHz, 1Gb, 60Gb HD, AGP graphics(nothing special), no sound.

I have always found it to struggle when transferring files, especially once the size of the files/folders go over 50Mb. During transfers like this the mouse etc on the Linux box is VERY unresponsive. Obviously running without X would improve this.

But when I use my NT box in place of the Linux box, NT specifications as ffollows:

AMD K6III 450MHz, 128Mb, 120Gb HD, AGP graphics(nothing special), no sound.

There is no such problems, I can transfer files to and from the NT box to my two other Windows machines, also surf the net from the NT box at the same time.

I alwasy put this down to samba, but recently I have experimented with other applications on the RH7 Linux box and found them to be much slower than that of comparable applications when run on a Windows machine.

In answer to the initial post, I don't think increasing the power and specifications of the Linux box so that it performs comparably to that of a Win NT box is the answer. This is one area, that I have felt let down by Linux, it seems to require greater specifications to match a Win NT box in performance.
 
Old 04-20-2003, 11:29 AM   #38
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
I would imagine you are running a linux system built for a 386 machine on your computer.

Linux is distributed by the larger distros with the aboility to run on older machines. If you want performance you will need to do some code building.
 
Old 04-20-2003, 12:19 PM   #39
taarnak
LQ Newbie
 
Registered: Feb 2003
Distribution: Redhat, Solaris, Suse, Debian
Posts: 16

Rep: Reputation: 0
I noticed that earlier you posted some slowdown that was affected by file transfers through Samba, have you tried to do file transfers through FTP or RCP so you can bypass Samba and see if the issue is the OS or Samba?
If you don't have the FTP or Telnet server installed, download Putty for your Windows machines which will allow you to use SSH and keep your Linux box secure from plain text passwords.

On a side note, you would never get this kind of helpfull information regarding any other OS out there in one forum as you do here.
I have had countless problems solved just from reading through the posts written by some of the Linux veterans here and many helpfull tips that I have implemented to make life easier.
Thanks for sharing your knowledge.

Last edited by taarnak; 04-20-2003 at 12:23 PM.
 
Old 04-20-2003, 08:41 PM   #40
nyfaisal
LQ Newbie
 
Registered: Apr 2003
Posts: 25

Rep: Reputation: 15
Okay. RAM, network speed shouldnt matter. If it runs fast with NT 4, it should NOT run so slow with linux. Linux now has a good network hardware support similar to NT4 at least, so I wouldn't think its the hub/ ethernet card. Try taking the hdd out of pii 450, and put in amd k6 500, and see if you have similar performance as the pii. Amd K6 is a very slow processor, even slower than celeron 400, and meant for low-end use. PII , on the other hand was standard pentium upgrade for workstations and desktops. So, I'd guess your computer is just slow. I had a k6 450, and RH 7.3 used to run slower than my Pentium 166 box on that. <p>I agree with speck, to optimize the settings, you shouldn't run kde or gnome, get some slick window managers if you need gui- probably reinstall Linux as a file server [take out multimedia, python, bla bla appz]. You can always add 'em later if you need them. Remember, NT 4 doesn't come with a lot of appz other than Notepad wordpad and IE. But probably your linux install had a lot of other appz and daemon running at startup. Try re-installing with minimum appz that you'll need.
 
Old 04-20-2003, 08:47 PM   #41
nyfaisal
LQ Newbie
 
Registered: Apr 2003
Posts: 25

Rep: Reputation: 15
Try updating samba to the latest version. Anyone knows about any other samba-like server?
 
Old 04-20-2003, 10:41 PM   #42
Whitehat
Senior Member
 
Registered: Feb 2003
Location: The Cold North
Distribution: SuSE 9.1
Posts: 1,289

Rep: Reputation: 46
Hmm...

I hate to say this but....

Windows 2000 server and even NT4 Server, is a dang good server OS. If the box is not used to surf the web, and it is behind a firewall and it NOT accessable to the outside world....you have no worries.

If you have such good luck with Windows, why move away from it?

I just tried to do that and was not very successful. I have come to the conclusion that when I have a specific use for linux and linux fits that use well, I will switch (or at least use it for that specific use).

Until then, I'll use WinXP on the desktop. It's just dang fast, it don't crash, it runs my games, shares files, and more.

I learned not to be so "gung-ho" about leaving windows behind, as it has it's place just like Linux does.

I personally know that at my workplace we have file servers that are Pentium Pro 200MHz boxes running Windows NT Server 4.0. Those boxes have 300+ people accessing them at most times. Considering we have about 2800 employees. They work just fine. Would those boxes run Redhat Linux 8 or 9 in command line mode? Sure, and they'd run fine. Would they run the GUI? Sure, and they'd run it like crap.

People need to not discount the value and goodness of Windows. They didn't get where they are today by sucking all the time....just some of the time

Later...
 
Old 04-20-2003, 11:16 PM   #43
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware
Posts: 1,348

Rep: Reputation: 217Reputation: 217Reputation: 217
I'm no netwoking expert but I read this thread because I'm going to be trying the same thing in my office in the near future.

The whole mouse sluggish comment reminds me of how my machine runs when a process is out of control and my CPU usage is stuck at 97.2%

Have you checked the CPU usage when the server bogs down and run top to see if there is a process thats out of control and is it the same thing every time?
 
Old 04-20-2003, 11:54 PM   #44
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
A server for that many is not supposed to even have a mouse. It probably should not even have a monitor and keyboard, except for installation and problems.

A server should never be used as a desktop machine. I think that if you have only one machine it should not be a server. If you have more than one then one of them can be a server.

There is no need for a window manager on a server, but if you must install X on it then twm or wmaker is a good choice. The server should always be booted into runlevel 3.

Linux will make a great secure server. You just can't expect it to be a desktop machine at the same time. It's just not supposed to be used that way. And Windows 2000 server should not be used that way either.
 
Old 04-24-2003, 08:08 PM   #45
tangle
Senior Member
 
Registered: Apr 2002
Location: Arbovale, WV
Distribution: Slackware
Posts: 1,761

Rep: Reputation: 78
Linus, what is the setup of the NT server that you want to replace? You mentioned that the Linux box has one 20 gig IDE hard drive. That is probually the cause of your problem. You have the OS and the user request for file hitting that single hard drive all at once. Since you have 14 users accessing that server, a single hard drive is not an ideal setup. I think that if you would add a (let say) 4 gb hard drive for the OS and put the data that you want to share on the 20 gig hard drive you would see better preformance. 14 users is not a lot, but if they all request data at the same time it would bag down the server.
Also I have noticed that distro's like Red Hat and Mandrake run a little on the resource demanding side. I changed one of my servers over to Slackware and it runs a lot faster. If you wanted to get rid of the GUI and still have an easy way to configure you server try Webmin. It lets you use a web browser on another machine to configure it. I like it. Also go to http://www.valkyrie.net/~tangle/comp.../smb_conf.htm. I have my smb.conf file posted and a little how-to. It might help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora 2, gimp2, wacom, pressure problem tomekp Fedora 1 12-23-2004 03:54 AM
What can these linux servers handle? sendas4 Linux - Networking 3 09-16-2004 06:07 PM
HANDLE support for Linux sheenak Programming 11 05-03-2004 08:18 AM
boss's pressure for usb storage joesbox Linux - General 7 04-30-2003 06:16 PM
linux related blood pressure problems!!!!!!! bigjohn General 5 07-25-2002 03:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration