-   Linux - General (
-   -   LILO fix failure (

RiderG7 07-14-2012 05:33 PM

LILO fix failure
Recently I tried to fix a 15-years-old pc by installing on it DSL.It's first OS was windows98 and i deleted it in order to take full advantage of the disk space(2.5 Gb!).For the installation I followed this:
I created a swap partition(hdc1:500MB)and the bootable partition(hdc2:2GB).Everything was fine and i choosed to have LILO as boot loader.
But when I restarted i got the "L 99.." error.After a little google search I tried editing lilo.conf and run lilo install again,through dsl live cd.
Now I have to deal with this error:

Fatal:creat  /boot/map~:Read-only filesystem
I tried chroot but when I type:

chroot /mnt/hdc/bin/bash
I get error:

/bin/bash:not a directory
When I delete "bin/bash" chroot is succesfull but lilo still can't run.
When run "chroot /mnt/hdc2" and I'm typing from "root@box" I get the error:

Fatal:cannot open /dev/hdc:permission denied
If then I try "su lilo" it says "invalid id:lilo"
I found a thread with the same error here: it gives no certain answer to the problem.
So how can I reconfigure lilo when I'm root but still have "access denied errors"????
EDIT:partially resolved.It was because of nodev that i couldn't edit lilo.
The solution was:

mount -o dev /dev/hdc2
I finally updated lilo with lilo -M /dev/hdc.
But when I reboted I get "No boot signature in partition".

EDIT2: I tried re-editing lilo.conf and use lilo -A to activate hdc2 but got:"no changes to partition table..." and the problem remains.

All times are GMT -5. The time now is 03:40 PM.