LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   "LI" from boot floppy? Can't load XP or Linux. Damaged MBR or boot sector or ...? (https://www.linuxquestions.org/questions/linux-general-1/li-from-boot-floppy-cant-load-xp-or-linux-damaged-mbr-or-boot-sector-or-31051/)

SparceMatrix 09-23-2002 05:57 PM

"LI" from boot floppy? Can't load XP or Linux. Damaged MBR or boot sector or ...?
 
I had Windows XP Pro loading both itself and Linux. This was pretty successful until recently when I was trying to add a second scavanged hard drive. Now, I am getting "A disk read error occured" when I try to boot up my system. When I try to boot from the Linux boot floppy, I get only the message "LI" from LILO and nothing else.

What is going on? What is the significance of the "LI"? I suspect a boot virus, but my McAffee rescue disk doesn't find anything -- although it is over a couple years old.

DavidPhillips 09-23-2002 08:33 PM

added what where?


sounds like a jumper problem


or you changed the position of your drives

stickman 09-23-2002 09:42 PM

Try a search for "LILO stops at LI" on Google. IIRC, it's a fairly common issue that's related to disk geometry.

hanzerik 09-23-2002 11:17 PM

Yea it looks like your system is trying to boot from the, new harddrive and cant find the kernel. What does your bios say when the computer boots? which drive is master and which one is slave?

SparceMatrix 09-25-2002 12:04 AM

I don't think drive locations are the problem, I think that the MBR or something has been permanently corrupted. I tried upgrading (repairing) the Linux part of the installation on the drive and now I am getting "kernel image not found" when I boot from the rescue floppy even though the kernel image is right where it is supposed to be. Booting from the hard drive continues to give the "disk read ..." errors.

adam_boz 09-25-2002 05:51 AM

No, I'm pretty sure that your mbr is o.k. I got the same error not too long ago. the "LI" is an error message for a particular problem... i think that it loads the bios but then can't find the mbr or something (I forget) search around on google, I found a table explaining every lilo error message. Do you have a windows rescue disk? I'm sure there's a way to boot your linux kernels, but i don't know how. How about putting LILO on a boot disk?

DavidPhillips 09-25-2002 07:49 AM

XP will switch the drive assignments, you need to boot to a root boot disk and look and see what you have with fdisk

SparceMatrix 09-25-2002 12:05 PM

I've been in under the Recovery Console and used the command 'map' and 'fdisk' and all the partitions seem to be in place. I am using the NTFS.

bigjohn 09-26-2002 10:27 AM

sounds like ????????????
 
Not sure if it's any help but your snag sounded like one of the abortive attempts that I had when I was trying to set up my dual boot (single hdd).

I had already re-installed my XP and mandrake 8.2 successfully when I found the repair facility that would reinstall the windows MBR by way of a rescue.

Sorry, don't know about deadrat!

regards

John

MasterC 09-27-2002 05:46 AM

We must all sound like crack pots, but it really does just sound like a jumper issue of some sort.

Most of the distros now have a "rescue" option. Sometimes in the rescue mode you even have an option to "reinstall" lilo to the MBR. To get into this, plug in your install CDROM, and at the first screen (where you can usually hit F1 to see help or more install options) hit F1 and type rescue, or read the documenation there and go into rescue mode.

The thing is, that even if you do reinstall LILO to the MBR, if your jumpers are backwards, and it install LILO to the MBR of the wrong disk, it still won't boot. Try switching the jumpers of the rescue option doesn't work. Let us know what you find...

Cool

SparceMatrix 09-27-2002 02:20 PM

Here is what I found:

I had my BIOS settings for my hard drives set to AUTO. When I reset them them in the BIOS, I find that I can boot up again. It appears to be a BIOS problem, but I do not rule out a virus corrupted boot sector. There are too many cockroaches out there spreading these things around. It could be that resetting my BIOS has bypassed the virus.


All times are GMT -5. The time now is 03:29 AM.