LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   lexmark z13 printer can't get driver (https://www.linuxquestions.org/questions/linux-general-1/lexmark-z13-printer-cant-get-driver-135266/)

degraffenried13 01-15-2004 09:09 PM

lexmark z13 printer can't get driver
 
Is there another tool to use to add printers? From the command prompt I started redhat-config-printer and tried to add my lexmark z13 printer. The drivers weren't there so i downloaded the tar file from lexmarks site and ran the *.sh file. It supposedly installed everything. It put 20files in /usr/local/lexmark/ folder.

I noticed that all of the other drivers were .xml files and they were in /usr/share/foomatic/db/source/driver, but none of the z13 files were .xml files so I couldn't just move them into there.

So in the config the z13 doesn't show up. Is there a way to force foomatic to find the z13 drivers or is there a shell prompt config for printers that would be good to use.

Tinkster 01-15-2004 09:15 PM

Have a look there ...

http://www.linuxprinting.org/show_pr...um=Lexmark-Z13

linuxprinting.org is the most authoritative
source of info on printers ...




Cheers,
Tink

degraffenried13 01-15-2004 09:41 PM

Quote:

Originally posted by Tinkster
Have a look there ...

http://www.linuxprinting.org/show_pr...um=Lexmark-Z13

linuxprinting.org is the most authoritative
source of info on printers ...




Cheers,
Tink

Thanks I will try that, I found that site once before, but got side-tracked on the lexmark site and forgot about it.

thanks again

IBall 01-15-2004 10:17 PM

linuxprinting.org lists this printer as a PaperWeight.

I used to own one, it worked fine with windows, but not with linux, even though I had a distro that Lexmark claim is supported, so I ended up chucking it out :cry:

I don't think that Lexmark should be able to claim to support linux, when clearly they dont. I suppose you could actually call it false advertising or something.:tisk: What does anyone else think.

From Ian

degraffenried13 01-16-2004 08:30 AM

If I can't get this thing to work, I will agree with you because they are getting my hopes up that I will have a working printer soon with my computer.

degraffenried13 01-16-2004 11:50 PM

I posted this at linuxprinting.org, but I haven't gotten any response over there so I thought I would try here. Any ideas?

>
> In article <bu7lnv$b4e$1@poblano.linuxprinting.org>, degraffenried13@yahoo.com
> (Shaun Upjohn) writes:
> >
> > I downloaded and ran the foomatic program that I found on this site for the
> > lexmark z13, and got all the way to the point in the program where it asks if
> I
> > use CUPS, I said both yes and no and received the error:
> > "Could not install your printer with Foomatic! at /usr/sbin/lexmark install
> > line 237, <STDIN> line 4."
> >
> > Any ideas?
>
> The above may be a symptom of what I am experiencing now. I found the z13
> driver when I went to add the printer, but the cpu won't communicate with the
> printer (ie it won't send anything to it to print) It finds the printer okay,
> but won't do anything after that.
>
> the printer is attached to dev/usb/lp0

After deleting the printer out of printer configuration in redhat, I then re_ran the footmatic lexmarkinstall file and it installed the file fine using cups. But the computer won't print a test page or print through lp.

degraffenried13 01-17-2004 09:51 AM

I upgraded cups to 1.1.20 and upgraded redhat-config-printer to 0.6.47, and now I can se the errors that show up. Here is what is processed by config-printer:

I [17/Jan/2004:10:47:51 -0500] Adding start banner page "none" to job 19.
I [17/Jan/2004:10:47:51 -0500] Adding end banner page "none" to job 19.
I [17/Jan/2004:10:47:51 -0500] Job 19 queued on 'printer' by 'root'.
I [17/Jan/2004:10:47:51 -0500] Started filter /usr/lib/cups/filter/pstops (PID 1878) for job 19.
I [17/Jan/2004:10:47:51 -0500] Started filter /usr/lib/cups/filter/cupsomatic (PID 1879) for job 19.
I [17/Jan/2004:10:47:51 -0500] Started backend /usr/lib/cups/backend/usb (PID 1880) for job 19.
W [17/Jan/2004:10:47:51 -0500] [Job 19] Media tray empty!

Thanks for any thoughts. I am running out of ideas to try.

jsmarshall85 01-17-2004 11:25 AM

i agree. i have a lexmark z605 and the only driver they have for it is a hedhat 9 driver. cant seem to get it to work on my slack9.1 box

to be honest though, im not sure what printing system i have running. i think it is the unix LPD print system. my printer is USB and USB is enabled in the kernel and other things like my keyboard that use usb work fine, but i cant get my printer installed.

any help would be appreciated


All times are GMT -5. The time now is 08:54 PM.