LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Kubuntu Shut Down: Blank Screen (https://www.linuxquestions.org/questions/linux-general-1/kubuntu-shut-down-blank-screen-537139/)

mertle 03-13-2007 02:41 PM

Kubuntu Shut Down: Blank Screen
 
I've seen similar topics posted numerous times, and I'm sorry for another, but I can't seem to find an answer that works for/pertains to my problem.

I'm running Kubuntu Edgy on a Dell Inspiron 9300 Laptop and an ATI Mobility Radeon X300 using fglrx. When I go to shut down, the screen does a few vid card flickers, but I don't get the shut down splash- everything just goes blank. Not even a blinking cursor. If I wait a few moments, my fans kick on.. a sure sign that my CPU is going full tilt.

I'm unable to Ctrl+F2 to get to a login prompt and end up having to manually power off the machine (I believe that the LCD is turning off before it should, so while I probably could use Ctrl+F2 to get back in, I simply can't see it 'cause the display is off).

This is my second installation of Kubuntu (did a freshy last week) and when I first had it installed, shut own worked fine, but I couldn't suspend. Now, I'm able to suspend and resume when I open the lid (though sometimes it works, sometimes it doesn't) but not shut down. Rebooting gave me a blinking cursor ever so often, but that seems to be working fine, now.

I don't think I've installed or did anything all that differently from my previous installation, so I dunno what might have changed. I've been going through my system with a fine tooth comb, fixing/tweaking issues that arise, and all has been going rather well 'n smooth.. but this is one annoyance I can't seem to troubleshoot on my own.

Is there something I need to add to my xorg.conf? Maybe something to do with ACPI?

Thanks in advance.
- mertle

EDIT: I thought I'd add a few configuration files to this post so mebbe people can point out some flaws. For the most part, they haven't been tweaked very much.

/etc/default/halt :
Code:

# Default behaviour of shutdown -h / halt. Set to "halt" or "poweroff".
HALT=poweroff

/etc/X11/xorg.conf :
Code:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        # path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath        "/usr/local/share/fonts"
EndSection

Section "Module"
        Load        "i2c"
        Load        "bitmap"
        Load        "ddc"
        Load        "dri"
        Load        "extmod"
        Load        "freetype"
        Load        "glx"
        Load        "int10"
        Load        "type1"
        Load        "vbe"
        Load    "dbe"
EndSection

Section "InputDevice"
        Identifier        "Generic Keyboard"
        Driver                "kbd"
        Option                "CoreKeyboard"
        Option                "XkbRules"        "xorg"
        Option                "XkbModel"        "pc105"
        Option                "XkbLayout"        "us"
        Option                "XkbOptions"        "lv3:ralt_switch"
EndSection

Section "InputDevice"
        Identifier        "Configured Mouse"
        Driver                "mouse"
        Option                "CorePointer"
        Option                "Device"                "/dev/input/mice"
        Option                "Protocol"                "ExplorerPS/2"
        Option                "ZAxisMapping"                "4 5"
        Option                "Emulate3Buttons"        "true"
EndSection

Section "InputDevice"
        Identifier        "Synaptics Touchpad"
        Driver                "synaptics"
        Option                "SendCoreEvents"        "true"
        Option                "Device"                "/dev/psaux"
        Option                "Protocol"                "auto-dev"
        Option                "HorizScrollDelta"        "0"
EndSection

Section "Device"
        Identifier        "ATI Technologies, Inc. M22 [Radeon Mobility M300]"
        Driver                "fglrx"
        BusID                "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier        "Generic Monitor"
        Option                "DPMS"
EndSection

Section "Screen"
        Identifier        "Default Screen"
        Device                "ATI Technologies, Inc. M22 [Radeon Mobility M300]"
        Monitor                "Generic Monitor"
        DefaultDepth        24
        SubSection "Display"
                Depth                1
                Modes                "1440x900"
        EndSubSection
        SubSection "Display"
                Depth                4
                Modes                "1440x900"
        EndSubSection
        SubSection "Display"
                Depth                8
                Modes                "1440x900"
        EndSubSection
        SubSection "Display"
                Depth                15
                Modes                "1440x900"
        EndSubSection
        SubSection "Display"
                Depth                16
                Modes                "1440x900"
        EndSubSection
        SubSection "Display"
                Depth                24
                Modes                "1440x900"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier        "Default Layout"
        Screen                "Default Screen"
        InputDevice        "Generic Keyboard"
        InputDevice        "Configured Mouse"
        InputDevice        "Synaptics Touchpad"
EndSection

Section "DRI"
        Mode                0666
EndSection

Section "Extensions"
        Option                "Composite"                "false"
EndSection

/etc/default/acpi-support :
Code:

# Comment the next line to disable ACPI suspend to RAM
ACPI_SLEEP=true

# Comment the next line to disable suspend to disk
ACPI_HIBERNATE=true

# Change the following to "standby" to use ACPI S1 sleep, rather than S3.
# This will save less power, but may work on more machines
ACPI_SLEEP_MODE=mem

# Add modules to this list to have them removed before suspend and reloaded
# on resume. An example would be MODULES="em8300 yenta_socket"
#
# Note that network cards and USB controllers will automatically be unloaded
# unless they're listed in MODULES_WHITELIST
MODULES=""

# Add modules to this list to leave them in the kernel over suspend/resume
MODULES_WHITELIST=""

# Should we save and restore state using the VESA BIOS Extensions?
SAVE_VBE_STATE=true

# The file that we use to save the vbestate
VBESTATE=/var/lib/acpi-support/vbestate

# Should we attempt to warm-boot the video hardware on resume?
POST_VIDEO=true

# Save and restore video state?
# SAVE_VIDEO_PCI_STATE=true

# Should we switch the screen off with DPMS on suspend?
USE_DPMS=true

# Use Radeontool to switch the screen off? Seems to be needed on some machines
# RADEON_LIGHT=true

# Uncomment the next line to switch away from X and back again after resume.
# This is needed for some hardware, but should be unnecessary on most.
# DOUBLE_CONSOLE_SWITCH=true

# Set the following to "platform" if you want to use ACPI to shut down
# your machine on hibernation
HIBERNATE_MODE=shutdown

# Comment this out to disable screen locking on resume
LOCK_SCREEN=true

# Uncomment this line to have DMA disabled before suspend and reenabled
# afterwards
# DISABLE_DMA=true

# Uncomment this line to attempt to reset the drive on resume. This seems
# to be needed for some Sonys
# RESET_DRIVE=true

# Add services to this list to stop them before suspend and restart them in
# the resume process.
STOP_SERVICES="mysql "

# Restart Infra Red services on resume - off by default as it crashes some
# machines
RESTART_IRDA=false

# Switch to laptop-mode on battery power - off by default as it causes odd
# hangs on some machines
ENABLE_LAPTOP_MODE=false


Matz 03-14-2007 09:15 AM

suggestion is to add "acpi=off apm=power_off" to menu.lst and "apm power_off=1" to /etc/modules

what happens if you give from konsole poweroff -h now?

tredegar 03-14-2007 02:13 PM

If you are not seeing the shutdown messages, and are unable to get a login screen with <CTL><ALT><F1>, try appending vga=normal to the kernel boot line in menu.lst

Matz 03-16-2007 04:27 AM

@mertle

Did you fix your problem? The curious thing is that I started experiencing the same one after I replied to your post. You are contagious! ;-)

mertle 03-16-2007 01:36 PM

Matz:

Well, yes and no. I actually ended up doing another fresh install (because I'm that anal retentive), and I don't seem to be having the problem anymore... but that's how it was last time. All was well, then I probably futzed with something (probably my ATI card, been playing with that often to see just what can and cannot be done with various drivers), and it broke my shut down. I haven't thoroughly tested standby/hibernation yet, though.

Should I still add your suggestions to /etc/modules?

As for being contagious... *bats lashes innocently* I'll try to cover mah mouth when I cough out a forum post, next time. ;)

- mertle

Matz 03-17-2007 04:06 AM

Quote:

Should I still add your suggestions to /etc/modules?
If ain't broken don't fix it! FYI I also fixed my shutdown problem by adding "acpi=force" in my /boot/grub/menu.lst file. It seems we are well synchronized

rapachooie 03-30-2007 01:20 AM

Hi all,

Im having the (seemingly) same problem. Running Kubuntu 6.10. When I am in a session and I log out, options for "restart" and "shutdown" lead to a blank screen (monitor switches off) and system just hangs.

This is about my 8th install of Kubuntu (Im a noob so I opt for the format when I mess something up, which is rather frequent since I like pushing buttons). But this problem happens by default on EVERY install Ive done so far. It works fine on my laptop, its obviously something specific to this setup. Im thinking hardware, maybe video card (Radeon 9600) but I just dont know what Im doing enough to figure out the problem.

I can "sudo reboot" or "sudo shutdown" from the konsole and that works fine but I cant get it from the buttons.

I did change ACPI settings somewhere (I dont remember the file name) but I told it to stop switching off the monitor when I reboot, and when I did that, shutting down/restarting led to the kubuntu status screen with blue bar and it just sat there for a few seconds, switched to a blank screen with flashing cursor and i could type whatever I liked, then after 3 seconds or so would switch back and hence be stuck in a loop.

If anybody has the solution please let me know!!! THANKYOU!!!

Matz 03-30-2007 04:51 AM

Please do not send private e-mails to LQ members (like you have done with me) as this is against LQ rules. If you have problems post it in the forum.

I didn't fix the problem: sometimes kubuntu shuts down properly and sometimes it does not. I suspect this is caused by some sort of conflict with wireless device, as when it is off I can shutdown from kde.

For the time being I'm shutting down typing "sudo poweroff -h now" from terminal, I will try to fix the problem in the next future.

rapachooie 03-31-2007 12:10 AM

Hi, sorry I didn't realise it was uncouth. Apologies. I wasn't sure if this thread was still being read. Sorry anyway.

But I doubt its wireless conflict in my case... my setup has no wireless (Ive got a WAG54G but wifi is off and nix has no details of wireless.

Ill stick with poweroff -h thanks for that.

Cheers

Matz 04-23-2007 04:36 AM

FYI: after having upgraded kubuntu to 7.04 version (Feisty), the shutdown problem got fixed. You might want try that way, too.

inportb 04-25-2007 11:01 AM

Hm, upgrading to 7.04 is precisely what caused this problem to appear on my laptop (w/ ATI Radeon™ Xpress 200M), and only when fglrx is used. I'm going to try some of the suggestions and see what happens... This is actually the first description I've come across that exactly mirrors what I'm experiencing.

skullmunky 06-12-2007 08:23 PM

inportb,

did you ever fix this problem with the logout on your laptop? i think i have the same problem - log out gives me a black screen instead of the GDM login screen, nothing can be done except hard reboot. also an ATI 200M card, with fglrx drivers; the problem also started for me after uprading from edgy to feisty. it's a single-user laptop so i rarely log out, but it's still vexing.

inportb 06-13-2007 09:55 AM

Hm. Actually, I had fixed this problem on my laptop a while ago; my apologies for not posting the solution here. I agree that it's a very annoying situation, and I had resorted to either using the commandline to reboot/shutdown or killing X the ctrl+alt+bksp way to just logout... then I realized that killing X held the key to the solution --

http://ubuntuforums.org/showthread.php?t=420999

Good luck!


All times are GMT -5. The time now is 05:46 AM.