LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   kmod : Failed to exec /sbin/modprobe (https://www.linuxquestions.org/questions/linux-general-1/kmod-failed-to-exec-sbin-modprobe-160874/)

urzumph 03-22-2004 07:35 AM

kmod : Failed to exec /sbin/modprobe
 
OK, What I am trying to do is install a new kernel (2.4.25) on a debian server. (The HP Officejet Drivers need >2.4.20)

Now, I have gotten a fair way, It'll even boot, until it comes to loading modules, upon which It repeats into infinity :
kmod : failed to exec /sbin/modprobe -s -k binfmt-0000, errno=8

Now, I have checked, /sbin/modprobe exists as a symlink to /sbin/insmod .
I thought at first taht this might be because it doesn't like the symlink, so I mv'd the symlink and cp'd insmod to modprobe. No go. The symlink is now back in place.

Another possible solution I found was compiling support for all binary types into the kernel. Done, and it still doesn't work.

I have tried adding alias binfmt-0000 off to my modules.conf. No go there either.
(now commented out)
Any thoughts?

TIA

trickykid 03-22-2004 02:04 PM

You most likely need to update the mod-utilities package to the latest version.

urzumph 03-22-2004 05:44 PM

I upgraded to modutils 2.4.25 and then to 2.4.27, and still get the error :(

urzumph 03-23-2004 10:18 PM

Well, it's a less than satisfactory outcome, but disabling initrd makes it work.... I wonder why?


All times are GMT -5. The time now is 10:40 AM.