Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 11-15-2003, 07:29 AM   #1
LQ Newbie
Registered: Jul 2003
Location: Germany
Distribution: Slackware
Posts: 18

Rep: Reputation: 0
Kernel Panic with LiLo


I just installed Slackware 9.1 but when booting on hdc9 (this is where root is mounted) there is a kernel panic:

WARNING: Failed to open an initial console
Kernel Panic. Try to pass init= option to the kernel

I checked the /ec/lilo.conf and everything seems to be allright. Although the root filesystem is ext2, it seems as LiLo mounts a riserfs-partition as /. I don not even have one reiserfs-partiotion on my PC. ???
Dos anybody have an idea how to fix this so that I get my slackware up and running? I would be very thankful!

Last edited by Rabon; 11-15-2003 at 09:08 AM.
Old 11-15-2003, 09:09 AM   #2
LQ Newbie
Registered: Jul 2003
Location: Germany
Distribution: Slackware
Posts: 18

Original Poster
Rep: Reputation: 0
sorry, the problem is kind of fixed since I made a second install of slackware... Now everythig works fine
Old 01-25-2004, 09:30 PM   #3
Registered: Oct 2003
Location: USA, Tennessee
Distribution: Ubuntu
Posts: 307

Rep: Reputation: 30
I have reinstall 5 times... I get the same thing.... what could be wrong?
Old 01-25-2004, 10:09 PM   #4
Registered: Nov 2003
Location: Canada
Distribution: ArchLinux
Posts: 324

Rep: Reputation: 30
Check your hda /etc/fstab (with knoppix or a floppy). I would suspect the install has neglected to put the hda info in and thus there are missing mount points. Knoppix will let you edit this and put them in by hand if you know what to put in (should look like the ones in /etc/fstab in knoppix, only the mount point will be '/' instead of /mnt/hda1' or whatever). I have also seen a thread somewhere where someone had put /boot on its own partition and not sent the kernel the location, I cannot remember exactly.

I had the same problem with the new mandrake beta. I was able to install by manually partitioning the HD, then selecting the mount points manually.

Last edited by colnago; 01-25-2004 at 10:14 PM.
Old 01-31-2004, 04:52 AM   #5
Registered: Dec 2003
Location: Rio de Janeiro
Distribution: Debian Squeeze
Posts: 54

Rep: Reputation: 15
The same problem here. So, after installing Mandrake 10 beta 1 I configured Lilo, disabling those APCI and AP-don't-know-what-it-means :-) I just read it somewhere, and tried to disable these... and it worked!

In case you don't know how to do it: after installation is complete you get to the configuration screen. Then choose to configure the boot, and you'll get to this screen where the Aps-whatever will be. They're set active by defaul, so I just unchecked them. It worked for me.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic after lilo update aje Slackware 4 09-03-2005 01:39 PM
LILO and kernel panic confuted Linux - General 5 05-23-2005 06:24 AM
Kernel Panic: It won't mount the root filesystem (2.6.8 and 2.6.9) and LILO hates me edman007 Linux - General 4 11-13-2004 05:41 PM
LILO-related Kernel Panic on Boot sarboras Slackware - Installation 7 04-28-2004 04:28 PM
Lilo / Kernel Panic problem oulevon Linux - General 1 11-20-2002 08:53 AM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:13 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration