-   Linux - General (
-   -   Kernel Panic: unable to mount root filesystem... (

Firefox54 05-27-2011 05:10 PM

Kernel Panic: unable to mount root filesystem...
I am using GRUB bootloader. I can boot into windows fine. But booting into linux gives me the error "kernel panic: unable to mount root fs on unknown block(0,0)

I got LILO to load linux fine but GRUB always gives me this error regardless of the linux OS for this particular computer.

T3RM1NVT0R 05-27-2011 05:14 PM

@ Reply
Hi there,

Can you please paste the output of grub.conf or grub.cfg file (depends on the OS in use) here. It appears that the grub has got a wrong entry for root partition.

As you said you are able to boot in using LILO can you please paste the out of df -h as well as mount command here.

Firefox54 05-27-2011 05:49 PM

Sorry, I am not sure where to find this file.
I can run windows 98 from the hard drive and linux OSes from the cds.
For more info:
I have two hard drives(sda and sdb) sda hard drive has two partitions ext2 and fat32.

T3RM1NVT0R 05-27-2011 06:11 PM

@ Reply
Well it would have been better if you would mentioned the OS you are having trouble with.

grub.cfg and grub.conf files are located in /boot/grub/

Also if you are using CentOS, Fedora or RedHat I think following documentation will help you out:

Firefox54 05-27-2011 06:31 PM

right now I am running the computer with puppy live cd because win 98 doesn't see my ext2 partition. I am trying to boot legacy OS from the hard drive.

In puppy, in /mnt/sda2/boot/grub/ I don't see the grub.conf file or the grub.cfg . I see the menu.1st file as well as a lot of stage(fat_stage1_5, stage1, ufs2_stage1_5 etc.) files

TobiSGD 05-27-2011 06:39 PM

Your problem seems to be that you have your Linux on sda2 while Grub tries to boot from sda1. Open the menu.lst file you found with a text editor, search for the entry for your Linux distro and change the root (hd0,0) to root (hd0,1), then save the file and reboot.

Firefox54 05-27-2011 06:56 PM

I changed it and it still gives the same error message, (0,0)

TobiSGD 05-27-2011 07:03 PM

Please post the contents of that file. Please use code-tags (the #-button on top of the text-field) for that.

trey85stang 05-27-2011 09:20 PM

How old is this legacy os and what is it? menu.lst has not always been the grub configuration file nor has it always been stored in /boot/grub

Firefox54 05-28-2011 12:15 AM

Legacy is a spinoff of puppy. I think that I am just going to fill up one of my hard drives with unity and the other with win 98.

TobiSGD 05-28-2011 06:54 AM

Unity is not an OS, but a desktop environment that runs on top of Ubuntu. And if this really is a machine from the Windows 98 era then I doubt that it will run Ubuntu with Unity.
If you still want your issue solved then please post the menu.lst file.

Firefox54 05-31-2011 02:49 PM

I gave up on grub. Lilo worked perfectly with Debian.

All times are GMT -5. The time now is 10:20 AM.