LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Kernel Compilation issues (https://www.linuxquestions.org/questions/linux-general-1/kernel-compilation-issues-331460/)

Dr Croubie 06-08-2005 04:30 AM

Kernel Compilation issues
 
OK, so this is what happened (i don't know where the problem is, so i'll put in as much detail as possible):

I have suse 9.1, kernel 2.6.4-52 (that came with it). everything worked fine.
but i thought i would have a crack at compiling my own kernel.
so i downloaded kernel 2.6.11.11 from kernel.org (the cd didn't have kernel source on, so i got the latest).
following the directions in one of those (old) pocketbooks, i did all the usual:
make menuconfig
make dep && make clean
make bzImage
make modules
make modules_install
yada yada
but bzImage and System.map in /boot/
update lilo.conf

and reboot the new kernel.

it got as far as "starting network services.. done" and hanged.
rebooted with my old kernel, and i noticed that the line after that one is "syslog services".
anyway.
did "make menuconfig" a few more times, and i don't know what i changed, but now it gets to "loading linux2.6.11.11..." and hangs.

The weird thing is, rebooting with my old kernel works, but "smpppd" seems to be missing. whenever i try to start Kdial, i get a "smpppd may not be running, or broken" message. (and thus, no internet to be had).

So, to start with: can (& if so how can) i go back to the same configuration i had before trying the new kernel? then at least i can get on the net on lin, instead of switching between win for net and lin to recompile.

then: what debugging should i turn on and where should i look to find out the source of the non-bootage?

bathory 06-08-2005 04:48 AM

Copy the /boot/config-2.6.4-something to /usr/src/linux-2.6.11.11/ as .config
Code:

cp /boot/config-2.6.4-something /usr/src/linux/.config
assuming you made the symlink /usr/src/linux -->/usr/src/linux-2.6.11.11
and run:
Code:

make oldconfig
as first thing.

oneandoneis2 06-08-2005 04:51 AM

And you don't need to run all the rest of the dep, clean, etc. options. That's 2.4 stuff.

The complete set of commands I run for a 2.6 kernel is:

make menuconfig (or oldconfig)
make
make modules_install

Than copy the bzImage & Systemp.map to /boot. That's all that's needed with 2.6

Dr Croubie 06-09-2005 06:40 AM

well, ok, now it's just being weird...

so i followed your directions, thanks guys:
copied the old config file,
did a make oldconfig.
recompiled (with just the make / make modules_install)
updated lilo
rebooted.


it got back to where it did before, hanging after "starting network services.. done"
so now:
where's the file that lists, in order, what boots (so i can find the module that's causing the problems)?
if logging is enabled (idk if it is), where do i find the log file?
anyone got any other ideas why it's hanging?


(and here's another weird one:
after i reset, load the old kernel, and it goes to prompt only, can't startx, can't shutdown, can't reboot, have to ctrl-alt-del to reset.
load the old kernel again. goes to KDE, but has no smpppd.
reboot old kernel again, goes to prompt again, no x etc.
reboot old kernel again, goes to KDE, and everything's normal.
but that's probably just because i'm rebooting so often...)


All times are GMT -5. The time now is 09:10 AM.