LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Kernel compilation error: Error 15: File not found (https://www.linuxquestions.org/questions/linux-general-1/kernel-compilation-error-error-15-file-not-found-298484/)

Niceman2005 03-06-2005 08:20 PM

Kernel compilation error: Error 15: File not found
 
Dear all,

It is my first time to compile a kernel. I got this error when I boot with the kernel I compiled.

root (hd0,1)
Filesystem type is ext2fs, partition type 0x83
Kernel /boot/vmlinuz-2.4.26 ro root=/dev/hda2
Error 15: File not found


Is this error likely to come from the kernel configuration or the grub.conf?

thanks for any assistance..thanks a million

nonzero 03-06-2005 08:44 PM

It oculd be both. After you did 'make install' did you check /boot to see if your new kernel and it's related symlinks were installed correctly? Have you checked the structure of /boot/grub/grub.conf to see if it added your new kernel correctly?

nz

Niceman2005 03-06-2005 09:42 PM

Hi nonzero,

The kernel file is "vmlinuz-2.4.26"
I think there isn't any sym link created. Is it compulsory to create one? where to link it to?

In my grub.conf I realised I don't have the "initrd" line that is available in other kernel grub.conf configuration. Also the initrd file is not in my /boot. Could that be the reason for the error?
see below initrd missing for vmlinuz-2.4.26

drwxr-xr-x 4 root root 1024 Mar 5 11:51 .
drwxr-xr-x 22 root root 4096 Mar 7 10:08 ..
-rw-r--r-- 1 root root 46375 May 8 2004 config-2.6.5-1.358
-rw-r--r-- 1 root root 45815 May 8 2004 config-2.6.5-1.358smp
drwxr-xr-x 2 root root 1024 Mar 7 10:06 grub
-rw-r--r-- 1 root root 190522 Dec 30 09:24 initrd-2.6.5-1.358.img
-rw-r--r-- 1 root root 195496 Dec 30 09:25 initrd-2.6.5-1.358smp.img
drwx------ 2 root root 12288 Dec 30 17:19 lost+found
-rw-r--r-- 1 root root 239593 May 8 2004 System.map-2.6.5-1.358
-rw-r--r-- 1 root root 243573 May 8 2004 System.map-2.6.5-1.358smp
-rw-r--r-- 1 root root 1343652 Mar 4 15:55 vmlinuz-2.4.26
-rw-r--r-- 1 root root 1199031 May 8 2004 vmlinuz-2.6.5-1.358
-rw-r--r-- 1 root root 1282272 May 8 2004 vmlinuz-2.6.5-1.358smp


Below is my grub.conf:

title Fedora Core-up (2.6.5-1.358)
root (hd0,0)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.358.img
title Red Hat Linux (2.4.26)
root (hd0,1)
kernel /boot/vmlinuz-2.4.26 ro root=/dev/hda2


Hope can help me..thanks a million!

nonzero 03-07-2005 12:19 AM

No not compulsory just convention. Try changing the line 'root (hd0,1)' to
'root (hd0,0)' and give it a go. I find it interesting that you've got the 2.6.x kernel series installed stock, but you elected to build a 2.4.x. kernel. Just experimenting?

nz

Niceman2005 03-07-2005 02:54 AM

Hi nonzero,

Tried that, still the same error.

Yeah, I am trying to experiment this openmosix thingi. Because its manual and installation instruction are all in 2.4 series so I just chose 2.4 series. If I successfuly build one I will try it on 2.6 series kernel.

thanks a lot for your help,

SwimmingPenguin 03-20-2005 06:44 PM

Hi niceman I think your problem is in your grub config file

when you created your entry you pointed to /boot/vmlinuz-2.4.26 ro root=/dev/hda2 for your kernel. I believe in Fedora the default path in already /boot so really you are looking for /boot/boot/vmlinuz-2.4.26 ro root=/dev/hda2......this makes sense because the entry before for the 2.6 kernel contains no /boot in the path to the kernel

Hope that helped,
Tim

Niceman2005 03-20-2005 07:42 PM

Dear Tim,

I tried that, changed it to /boot/boot/vmlinuz-2.4.26 ro root=/dev/hda2

Still gave me the same error.
My senior told me because I am using fedora core 2. He said FC2 uses kernel 2.6, he said only if I use FC1 then it will work.

thanks for your help Tim,

SwimmingPenguin 03-20-2005 10:14 PM

You misunderstood me I meant for you to remove the /boot all together...not add another, sry for the confusing post

...So in the end your grub.conf should look like this....

title Fedora Core-up (2.6.5-1.358)
root (hd0,0)
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.358.img
title Red Hat Linux (2.4.26)
root (hd0,1)
kernel /vmlinuz-2.4.26 ro root=/dev/hda2

georanma 10-04-2007 04:41 AM

double...see below

georanma 10-04-2007 04:45 AM

im having a similar problem

i get to my grub menu and select my install and i get this message


booting 'gentoo linux 2.6.19-r5'
kernel /boot/kernel-gentoo-x86-2.6.19-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda3 udev

error 15: file not found

press any key to continue


this is my first time hand compiling a kernel as well....id appreciate some pointers on what i need to edit and how to get to that stuff. thanks


All times are GMT -5. The time now is 11:04 AM.