LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 08-08-2004, 01:20 PM   #1
gibiman
LQ Newbie
 
Registered: Aug 2004
Location: -
Posts: 16

Rep: Reputation: 0
Question Kernel 2.6.7 problem - My vfat partition won't mount automatically !!


I recently kompiled my kernel 2.6.7 and it actually worked after 10-20 compiles...Any way I finnaly managed to make it stable though it wouldn't mount my /dev/hda7 partition at boot !
When it mounts the current file systems it returns [FAILED]
when I mount it " mount -t vfat /dev/hda7 /mnt/blablal " it mounts rwxr--r-- ( ??????? no user write or execute )
when I try to mount it mount /dev/hda or mount /mnt/gibi it returns an error like
wrong fstype bad superblock .... u know the error

my /etc/fstab file has a line /dev/hda7 /mnt/gibi vfat umask=0,charcode=???, 0 0
I do not guarantee the accuracy of the details because i am not at my workstation right now ! Anyway the thing is that my fstab file ( which works fine with my kernel 2.6.3 ) is proprely set up but my vfat partition either does not mount correctly ( although umask is set to 0 ) either it does not mount at all !! If u have any sugestions... ( or u need further details )
 
Old 08-09-2004, 06:07 AM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
The actual line from your fstab file might be of some help here, but it sounds like you may not have vfat support.

Try doing
Code:
cat /proc/filesystems
and see if it lists “vfat”.

Did you compile in vfat kernel support as a module? If so, you may need to run
Code:
modprobe vfat
(or whatever the module's called) to get it to recognise the “vfat” filesystem before you can mount it. I'm not sure what magic you need to do to make the module be loaded automatically (no doubt someone else can tell you!).

Hope that helps,

— Robert J. Lee
 
Old 08-11-2004, 02:40 AM   #3
gibiman
LQ Newbie
 
Registered: Aug 2004
Location: -
Posts: 16

Original Poster
Rep: Reputation: 0
Nope :(

My vfat partition is loaded into the kernel ! I did a menuconfig with the old .config file and there it was[*] ! i did a lsmod and my vfat partition was loaded as a module ! I know it sounds strange but ... Any way thanks for the reply
 
Old 08-11-2004, 03:06 AM   #4
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
Re: Kernel 2.6.7 problem - My vfat partition won't mount automatically !!

Quote:
Originally posted by gibiman
when I mount it " mount -t vfat /dev/hda7 /mnt/blablal " it mounts rwxr--r-- ( ??????? no user write or execute )
Ah! Do you mean by this that it does mount but regular users can't execute it?

Try doing
Code:
mount -t vfat /dev/hda7 /mnt/blablal -o user
or adding the “user” option to /etc/fatab if you're mounting it that way.
 
Old 08-11-2004, 07:18 AM   #5
gibiman
LQ Newbie
 
Registered: Aug 2004
Location: -
Posts: 16

Original Poster
Rep: Reputation: 0
I alreaddy tried that :(

It seems to be a kernel problem ... I did not try to mount it with -o user but i did try to mount it with the /dev/hda7 ,users, option in /etc/fstab :-? I'm really out of ideas .. only root has write access to that partition ! And i would like it to be a astorage medium for both windows and linux modes ( that explains why i chose vfat .. because that dumb windows XP only recognises partitions made of pure microsoft material ) I ran out of ideas and decided to install a gentoo distribution ... Which gave other headaches and problems ! But , in my opinion having problems is the best way to learn linux ...
10x for replying to my thread ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vfat partition does not mount on lfs logicalfuzz Linux From Scratch 1 09-02-2005 11:12 AM
mount vfat partition manually during RH 6.0 install linuxify Linux - Laptop and Netbook 0 07-28-2005 03:11 PM
I just compiled a new kernel, but I can't mount my vfat partition. Royle Debian 4 02-17-2005 08:07 PM
FC3 vfat partition mount problem darkranger Fedora 2 11-23-2004 07:23 AM
USB PenDrive and 2.6.3 kernel vfat mount problem jarro Linux - Hardware 0 06-12-2004 05:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration