-   Linux - General (
-   -   Kernal Panic: No init found. Try passing init= option to kernel (

raees 03-17-2004 06:37 PM

Kernal Panic: No init found. Try passing init= option to kernel
Kernal Panic: No init found. Try passing init= option to kernel.

I rebuilded and rebooted my linux server , I got this message !!

What need to do ?


aeolus 03-17-2004 07:47 PM

Your kenel must have a bit of problem.I think you should rebuild your kernel as steps:
1.modify /usr/src/linux/Makefile,EXTRAVERSION=-8(if your system is redhat9,remove custom)
2.make mrproper
3.make menuconfig and save
4.make dep
5.make clean
6.make bzImage
7.make modules(if you select modules)
8.make modules_install(if you select modules)

aeolus 03-17-2004 07:51 PM

or if you ever changed your H/W settings?

arrruken 03-17-2004 08:12 PM

did you make sure the root and boot partitions file system type are included in the kernel and not modules? I had the same error and it was that before.

taillefer 03-17-2004 10:34 PM

are two sites that I found useful while recompiling my 2.6.3 kernel. Check it out..

alucard2 03-17-2004 11:09 PM

I had the same problem when I tried to compile 2.6.0. I think it needs an initrd image to be placed in the /boot.
Goto bzImage (newly compiled) directory and use mkinitrd to create initrd, copy it to /boot

taillefer 03-17-2004 11:45 PM

The main thing is to compile ext3 directly into the kernel _not as a module_


#make xconfig

Go to FileSystems & put a check on Ext3 journalling file system suport.

Then follow the usual steps -
#make bzImage
#make modules
#make modules_install
#make install

You _do not_ need to run make dep and make clean for ver 2.6 kernel

taillefer 03-17-2004 11:59 PM

will show you the way

raees 03-18-2004 09:40 AM

When I made a boot floppy disk for linux.. My notion was to have a disk like MSDOS boot disk ,which will give me a console that will alow me to go through the file systems and make necessary changes to reboot.. But the one I made did not look like that .. even after tried to boot the stuff with folppy .. I ran in to same problem of kernel panic ...

I know, all that i have to do is to change the grub.cofig for my system to work but

What a stupid stuff .. I can't even do that with this boot floppy ....

I don't know how i will recover from this


raees 03-18-2004 11:15 AM

Help please

aeolus 03-18-2004 06:54 PM

what is your system?Redhat or ....
If your system is RH,you can insert RH disc1,then enter rescue mode.
You might operate like you say above.

raees 03-18-2004 08:43 PM

How to start in rescue mode ?. Will there be a menue to select ..Or any special key ?

aeolus 03-18-2004 11:10 PM

When you insert RH disc1,run linux rescue

All times are GMT -5. The time now is 10:12 PM.