-   Linux - General (
-   -   KDE start menu and panel have died (

biggles 02-08-2003 09:13 PM

KDE start menu and panel have died
Running Rh8.0, kernel 2.4.18-24.8.0 and KDE.

I had a boot problem with my system due to memory. I now have it running again but my KDE start menu has all but disappeared and the quick launch bar at the bottom of the screen has done the same. Also the few entries in the start menu are plain folders not the ones I had before and the Kcontrol no longer has any icons in it either so I can't configure anything. The desktop is unchanged.

Any help would be greatly appreciated. I don't want to have to rebuild this from scratch.

Thanks in advance.


al123 02-13-2003 04:21 AM

I cannot help, but just to say that I've got the same problem.

I've reinstalled twice. Both times the system seems to be going fine. I log out, leave it overnight, then return and log in....desktop OK, but no application icons. The start menu just stops at the run command dialog.

Cannot be bothered to reinstall yet again - especially if it's going to do this every time.

Anyone have a suggestion as to how to resurect the menu icons?

Any help appreciated.


al123 02-13-2003 05:54 AM

Just had a bit of luck with this one.

I logged into the GUI as root, and added another redhat start menu button to the toolbar. Saved the changes and logged out.

Logging in as a normal user showed that my toolbar had returned.

This looks to be some sort of bug with the saving of desktop configurations, and I guess making the changes as root caused something to be rewritten.

Hope this helps


biggles 02-13-2003 07:18 AM

A follow up to my original post.

While searching for a solution to another problem, my cdrom drive not working (I have a reader and a burner. The burner is properly recognised and works but the reader won't. The problem with the cdrom is /dev/cdrom is not a valid block device. The symlink from hdc to cdrom is correct, the newide driver is ok because the burner works which is hdd.) so I could reinstall, I found a reference to running

> depmod -ae

to restore the cdrom after a reboot.

I ran it and rebooted and instead of fixing the cdrom it fixed my start menu, panel and control center. I don't know how or but it worked so I'm not too concerned with the details right now.

I hope this can help someone else.


arnold 02-13-2003 08:58 AM

pleasures of freeware: The same problem has happened to me.
The start menu is the contents of the /usr/share/applnk directory.
I saved the contents of this directory. When the problem occurs, I restore the directory contents.

al123 02-13-2003 09:13 AM

Thanks Arnold - guess what I'll be doing :)


All times are GMT -5. The time now is 06:58 AM.