-   Linux - General (
-   -   KDE had CPU 'spike' every 15seconds! HELP! (

dezireduser 11-02-2005 07:37 AM

KDE had CPU 'spike' every 15seconds! HELP!
Not Needed

fouldsy 11-02-2005 07:43 AM

What is the rest of your hardware setup? It sounds like a KDE service is running in the background and refreshing itself, but that's nothing out of the ordinary. Quite why it causes audio + video to stutter isn't too clever though. It doesn't appear to be knocking your CPU usage that much based on the data shown in gKrellM or whatever you have running. Do you have any other desktop or dock apps running under KDE that aren't loaded under Gnome?

dezireduser 11-02-2005 08:04 AM

Not Needed

fouldsy 11-02-2005 08:15 AM

If it's just your user account, within your home directory there should be a folder called .kde3 or similar, I'm not familar with where KDE keeps it's data. Logoff your desktop, then using a terminal, rename this folder using:

mv /home/username/.kde3 /home/username/.kd3old
replacing "username" with your own username, and ".kde3" with whatever the folder is actually called.

When you then log back into KDE with your account, it should recreate a new profile from scratch, meaning you would have to setup any desktop settings such as background, screensaver, etc. See if your problem is resolved.

dezireduser 11-02-2005 08:36 AM

Not Needed

Matir 11-02-2005 10:16 AM

You could try using 'top' to see if you can identify the responsible process.

dezireduser 11-02-2005 07:48 PM

Not Needed

dezireduser 11-06-2005 06:14 PM

Ok, finally had a chance to work on my computer, and found out it was the refresh interval of the mtaskbar that my bro installed.

Glad that's settled.


wpialum 11-22-2005 05:19 PM

I have this same problem with Gnome, and its causing my mouse to stop for this fraction of a second (I don't notice any problem with the keyboard).

It doesn't seem to be user-dependent, as I can see the pause when I'm at the gnome login screen.

Using GKrellm, I can see the spike to 100% about every 10 seconds or so.

I'm using Ubuntu on a Dell C600 laptop. Powernowd is disabled. I am using cpufreqd, but I tried it without cpu scaling enabled and still had this problem.

Any help you can offer is greatly appreciated.


dezireduser 11-23-2005 02:32 PM

try starting up in kde and see if you still have those pauses. If it doesn't pause, then it might just be gnome, or some package that's being installed with gnome, or a bootscreen engine. If that's the case then try renaming your .gnome directory to .gnomeold (make sure you're not in X, tho, or login as a different user, and go to your initial directory, and do the renaming), and restart X, and see if that helps (most likely not, since you're getting pauses at the boot screen).

Also, did you install any bootscreen/engine packages (like moodlin, or something?)

Can you try running it with all services (that you can think of) totally disabled?

Sorry I can't help, but your problem seems kinda strange... :(

Good luck!


wpialum 11-25-2005 10:53 AM

I disabled a bunch of modules and rebooted, enabing one module at a time until I found the problem, and I believe that I've at least identified the's related to the sppedstep frequency scaling modules.

When I load speedstep-lib, no problems, but to enable frequency scaling (PIII 850 mHz Coppermine) I also need to load speedstep-smi. The speedstep-smi module seems to be causing this problem.

I'm going to see if there are different modules I can load for this chipset to enable frequency scaling without this annoying mouse problem.

Thanks for the tips.

wpialum 11-25-2005 01:51 PM

...or so I thought.

Disabling the modules minimized the prolem, but did not make it go away. I notice that the stuttering coincides with a random hard drive read that occurrs every 10 seconds or so. I am monitoring with GKrellm and can see a spike (looks like a single read) just after the mouse hangs.

I'm testing for the "hang" by making circles with the mouse and waiting for it to temporarily stop (for like .2 seconds).

It's certainly not the end of the world, but annoying when you're using a program that requires a lot of mouse movement.


dezireduser 11-26-2005 12:07 AM

ok, so most likely, there is some package/program installed that's causing some type of system logging to occur every 10 sec (some info is being captured and recorded to disk every 10 sec). If you can find the program that's doing it (maybe speedstep-smi, or something else?), then you can compiled the sources with the refresh/logging disabled, or have the interval set at something like 1000sec instead. Had the same problem with taskbar v2 taking screenshots every 15sec, and saving them to disk.



auditek747 11-26-2005 04:22 AM

Try going to the KDE control center > Kde Components > Service Manager
and stop the "KDED Media Manager"

This is just a guess, but I have seen the "KDED Media Manager" in KDE 3.4
cause things like this if your kernel isn't just so. (hal and what not)

Looks like I wasn't I wasn't paying attention and dezireduser's KDE
problem is already solved. I hope this is the case anyway :)

All times are GMT -5. The time now is 12:53 AM.