-   Linux - General (
-   -   Issues with Fedora, cannot boot. File system check fails, no shell starts. (

Mamsaac 10-19-2009 06:45 PM

Issues with Fedora, cannot boot. File system check fails, no shell starts.
Using Fedora 12 with latest updates. In fact, I guess that the problem came with the update from this morning or one from yesterday, since I hadn't turned it off since then.

On start, an error is displayed telling me that the file system check failed and mentions that I will get a shell access and that it will restart after shell exits. The thing is, that I get a message asking me for either the login or to press ctrl+D, but neither work. If I press ctrl+D, it will send the same prompt again and if I press any verbose key (that is, excluding "alt", "ctrl" and those) it will automatically send the same prompt again. So, I can't use ctrl+D or try to write the login.

I decided to use an Ubuntu LiveCD (Jaunty) that I kept saved.

Started Ubuntu, installed the package lvm2. This is because Fedora is installed in a lvm partition.


root@ubuntu:~# vgchange -a y
  2 logical volume(s) in volume group "VolGroup" now active

root@ubuntu:~# fsck -y /dev/VolGroup/lv_root
fsck 1.41.4 (27-Jan-2009)
e2fsck 1.41.4 (27-Jan-2009)
F12-Alpha-i686-L contiene un sistema de ficheros con errores, se fuerza la revisión.
Paso 1: Verificando nodos-i, bloques y tamaños
Paso 2: Verificando la estructura de directorios
Paso 3: Revisando la conectividad de directorios
Paso 4: Revisando las cuentas de referencia
Paso 5: Revisando el resumen de información de grupos
F12-Alpha-i686-L: 158616/786432 ficheros (0.3% no contiguos), 1561967/3115008 bloques
root@ubuntu:~# fsck -y /dev/VolGroup/lv_root
fsck 1.41.4 (27-Jan-2009)
e2fsck 1.41.4 (27-Jan-2009)
F12-Alpha-i686-L: limpio, 158616/786432 ficheros, 1561967/3115008 bloques

That was the output. I'm sorry that it is in Spanish, but the translation is pretty much this: I used commands to see if lvm2 was working, then used vgchange -a y to activate it and then checked the file system using "fsck -y PATH". It detected errors. Then some more messages. I use "fsck -y PATH" again and it detects it clean.

First time I did this, I didn't use fsck twice. Anyway, I restarted and the same error happens on Fedora, as described in the beginning.

I would appreciate help and will provide with details if possible. Thanks in advance.

Geraldsmod 10-19-2009 06:53 PM

So basically,
1. You're Fedora is installed on an LVM partition and now it doesn't work.
2. You booted into the Ubuntu LiveCD and tried mounting the LVM partition and it didn't work.

Is this right?

Mamsaac 10-19-2009 07:09 PM

No, the mounting works. I can access the files perfectly.

What isn't working is fixing the file system. I can use fsck on it and it will tell me it's clean and after that I can mount the file system and check any files. Yet, when I restart, it tells me that file system check fails and then I can't do anything.

BTW, sorry if this post was "too serious" >_> I'm getting a bit cranky over this. Thanks for your interest in helping.

Geraldsmod 10-19-2009 08:10 PM

Well, I'm sorry. I don't know much about LVM filesystems, nor have I ever used a distro using that filesystem.

But if you can mount and read the partition, you could always make a backup of all the important data on there and then re-install Fedora.
I'd be a pain in the neck but it would work nonetheless.

John VV 10-19-2009 08:11 PM

you do know that fedora 12 is still in TESTING and has not been officially released .
i would not use a "still beta testing version of fedora" unless you DO KNOW how to fix something that is not working and be able to submit a bug report and a fix !!!!!

use fedora 11

Mamsaac 10-19-2009 11:05 PM

I ain't complaining John. I have a taste for using Alpha and Beta versions of pretty much anything I use (except Windows, if I ever have to use it :S). I'm still using Ubuntu (although right now I'm on Windows, damn job).

It's the third time that Fedora 12 gets screwed after an update (but I fixed it the previous two times), but this time I'm pretty much lost. I've been using it since the first Alpha came out.

I'm afraid that it might have something to do with the fact that I'm using ext4 :S I've solved problems like this with fsck with ext3 before with little issues.

Still, if anyone has an idea of how to solve this, I will appreciate it. I will keep trying myself on my free time (like I've been doing).

John VV 10-19-2009 11:53 PM

can you post the error in the boot.log

ext4 is NOT the issue here .Seeing as you are using LVM

This is because Fedora is installed in a lvm partition.
I am not a LVM guru so , i can not help with that.

tommylovell 10-20-2009 12:05 AM

I don't know ext4, but my ext3 experience as been that the -f flag on fsck is required to really repair filesystem damage.

Also, if you have dumpe2fs (in package e2fsprogs), does 'dumpe2fs -f /dev/VolGroup/lv_root' tell you the filesystem is clean?

Mamsaac 10-20-2009 02:27 AM

3 Attachment(s)
Attach boot.log and output of dumpe, as requested.

I do notice that there's nothing specially unusual on the boot.log (it's pretty much the same as the backups). No errors (and only warnings) displayed.

Also, I had to split the file of output, for it was 257kb (ah damn haha).

All times are GMT -5. The time now is 11:20 AM.