-   Linux - General (
-   -   Is there Flash Player for 64 Bit Linux (

manikantha 06-10-2005 10:51 PM

Is there Flash Player for 64 Bit Linux

I failed getting flash player for 64 Bit Linux . Can neone tell me where can I get 64 Bit Flash Player . I searched it in Google and saw people saying there is no 64 Flash Player Until now :( ,,, is it so . If it is so ,, is there any way I use the 32 Bit Flash Player ??.
Thanx in Anticipation.

mulciber 06-10-2005 11:07 PM

I hope there is a way as I am suffering from the same problem.

LinuxSeeker 06-11-2005 07:17 AM

Macromedia flash player should work.

glimmy 06-12-2005 12:48 AM


Originally posted by LinuxSeeker
Macromedia flash player should work.
It doesnt though. I have even tried installing it using 32bit emulation and it still wont work

manikantha 06-12-2005 02:35 AM

I too tried installing it.. but it saying that architecture X86_64 is not supported :(

ToastedToad 06-12-2005 03:52 PM

You will need to set up a 32 bit chroot to enable flash.

DaWallace 06-12-2005 07:05 PM

try this?

HellSpawn 06-27-2005 10:58 PM


Originally posted by DaWallace
try this?


I trying to try that right now :rolleyes:

I read that I have to use this patches
which I don know how to use with the source.... Any tip will do ;)

and when I run ./configure on the gplflash source dir, I get:


checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
appending configuration tag "F77" to libtool
checking for jpeg_destroy_decompress in -ljpeg... no
configure: error: *** GPLFlash requires libjpeg.

But I have libjpeg:
[root@localhost ~]# rpm -qa|grep libjpeg
[root@localhost ~]#

i386 and X86_64...

:Pengy: :confused: :scratch:

Any ideas??
Thanks for your atention

DaWallace 06-28-2005 12:37 AM

you need to install development files for libjpeg.. I have no idea what package that would be on fedora.. but google would probably be of some help.. something like libjpeg-dev

some features aren't implemented in gplflash though.. it can be somewhat annoying, fscommand for example.

HellSpawn 06-28-2005 08:09 PM

The patches!!
Well... that did it... and I needed xorg-deve and libmad-deve too :cool:

Now could you help me with the patch thing??
I don know how to apply those!!


purelithium 12-14-2005 04:28 PM

You have to do a manual install. Find the "flashplayer.xpt" and "" files from the "install_flash_player_7_linux" directory where you extracted the tarball. Copy these 2 files into your browser's /plugins/ directory and you'll be good to go!

this is just a fact of the install script only works on 32bit platforms, the plugin works fine.

Pup 12-31-2005 01:34 PM


I am having the same troubles. I have untarred the gplash-4.0.13.tar.bz2

than I try to ./config I get a whole lot of "no help" from it. the what I get is...

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking for C++ compiler default output file name... configure: error: C++ compiler cannot create executables
See `config.log' for more details.

can you make any sense out of this. I am hoping you have been through the same here. or hopefully someone has.


purelithium 12-31-2005 04:19 PM

Pup, have you tried what I suggesed by using the flashplayer supplied by Macromedia? I've had no problems with it.

HellSpawn 06-20-2006 02:25 PM

NSPLUGINWRAPPER got opensource, and know it works very good (for me at least) with the 32bist flash plugin on my Firefox 64bits (on Ubuntu 6.06 64bits)

You can find a how-to in the ubuntuforum:


Instructions to install:

1) Download the Plugin and the Viewer from
2) Install Alien, if not already installed.
3) Convert the downloaded rpm's to deb's (sudo alien -d *.deb)
4) Install the newly created debs (Install in this order: sudo dpkg -i nspluginwrapper-i386_0.9.90-2_amd64.deb, sudo dpkg -i nspluginwrapper_0.9.90-2_amd64.deb) -- If I got the order wrong, you'll know because it won't install.
5) Download the plugin you want to install, and extract the .so file. For example, to install flash, grab the tar.gz file from Macromedia's website, and extract
6) Move the plugin (example, to /usr/lib/mozilla/plugins. This is where nspluginwrapper stores the main plugin, so it's probably a nice folder to keep them.
7) Now we need nsplugwrapper to make the new plugin, so call: /usr/lib/nspluginwrapper/x86_64/npconfig -i /usr/lib/mozilla/plugins/ (if wanting the flash plugin, of course). Depending on whether or not you run that command with sudo, it will either end up in /usr/lib/mozilla/plugins, or ~/.mozilla/plugins. If you ran it as sudo, you'll need to link it to either your profile's plugins or the main plugins (/usr/lib/mozilla-firefox/plugins). Or copy, doesn't matter. The old plugin must not move, as it's path seems to become hard coded in the new plugin created (which has "npwrapper-" prepended to the old name).

All times are GMT -5. The time now is 12:43 AM.