LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-24-2006, 12:39 AM   #1
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Rep: Reputation: 30
Is there a way to make slack boot to console before kdm starts?


I need to stop kdm from starting during boot, is there a key combination that will stop kdm and X from starting and jump to a console?
 
Old 03-24-2006, 12:48 AM   #2
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Change your runlevel in "inittab" to 3

id:3:initdefault:

This will start in CLI...

startx will launch Window Mgr.

KC
 
Old 03-24-2006, 01:00 AM   #3
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by kencaz
Change your runlevel in "inittab" to 3

id:3:initdefault:

This will start in CLI...

startx will launch Window Mgr.

KC
I have no way of getting to a console to do that. Is there a way to get to a console before KDM starts?
Ctrl-F6 does not work. I was trying to get S-VIDEO working and really screwed up things.
 
Old 03-24-2006, 02:11 AM   #4
ntubski
Senior Member
 
Registered: Nov 2005
Distribution: Debian, Arch
Posts: 3,388

Rep: Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553
Ctrl+Alt+F1 should get you back to console after kdm starts. But can't you edit a file from KDE?
 
Old 03-24-2006, 02:16 AM   #5
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by ntubski
Ctrl+Alt+F1 should get you back to console after kdm starts. But can't you edit a file from KDE?
KDE does not start, I have no video except the boot up messages, then the screen goes black.
 
Old 03-24-2006, 03:29 AM   #6
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
You're using lilo as your boot manager, right?

At your boot menu, choose the option you want and on the command line at the bottom of the screen add the number 2, so your boot line will look something like:

Linux 2

and press enter. That will boot into runlevel 2.
 
Old 03-24-2006, 09:52 AM   #7
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Komakino
You're using lilo as your boot manager, right?

At your boot menu, choose the option you want and on the command line at the bottom of the screen add the number 2, so your boot line will look something like:

Linux 2

and press enter. That will boot into runlevel 2.
Yes, LILO but I have no place to enter 2, once I choose the option in lilo it starts booting.
 
Old 03-24-2006, 01:53 PM   #8
ntubski
Senior Member
 
Registered: Nov 2005
Distribution: Debian, Arch
Posts: 3,388

Rep: Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553Reputation: 1553
Just press 2 when the selection is on the menu item. Then press enter. Or wait, shouldn't that be 3

Anyways, if it's your xorg.conf that is screwed up, you should still be able to get to the console via Ctrl+Alt+F1
 
Old 03-24-2006, 07:37 PM   #9
PDock
Member
 
Registered: Aug 2004
Distribution: Slack10 & curr. tried numerous
Posts: 189

Rep: Reputation: 36
Slackware leaves tty6 as a console login even with a gui initdefault so if your lilo does not have a prompt or timeout= such that you can not add a 1 or 3 after the menu name then try ctl alt f6 at your black screen.
 
Old 03-24-2006, 08:36 PM   #10
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Quote:
Originally Posted by M$ISBS
Yes, LILO but I have no place to enter 2, once I choose the option in lilo it starts booting.
Just choose the option using the cursor key, don't press enter, and type a space then a 2, then press enter...or indeed as has been mentioned (and I forgot) press CTRL-ALT-F6 to get a console.
 
Old 03-24-2006, 09:05 PM   #11
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
I understand the suggestions about tty6, but I do not get a console I get a bunch of small, colored squares on the screen as if the console is there in a different video mode, None of it is legible. This happened after I tried to setup xorg.conf to work with S-Video out, I have switched to the xorg.conf I backed up but I still get the black screen and colored dots.
 
Old 03-24-2006, 09:25 PM   #12
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
I went ahead and ran xorgconfig and that fixed the problem. It looks like the fonts in xorg.conf were all gone. I have no idea why the backup I made did not work or why the fonts were gone....

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to autologin on console (no kdm) and how to start with different resolution? stormrider_may Slackware 12 03-28-2006 09:17 AM
kdm starts gnome not kde geomatt Slackware 8 04-19-2005 08:35 AM
KDM starts automatically from user console? Oh Cisco Debian 3 08-14-2004 08:52 PM
KDM console login problem reddazz Slackware 3 06-19-2004 12:11 PM
From kdm to Console SilenceX Linux - Newbie 1 09-02-2003 12:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 11:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration