-   Linux - General (
-   -   invalid compressed format (error=1) (

Goatdemon 12-06-2002 04:09 PM

invalid compressed format (error=1)
i get this error from lilo everytime i load linux with my 2.4.20 kernel, then it stops dead. what needs to be enabled in the kernel to stop this crap?

DavidPhillips 12-06-2002 04:49 PM

did you make it with make bzImage and copy bzImage to /

Goatdemon 12-06-2002 11:53 PM

i do

make mrproper
make clean
make dep
make clean
make bzImage
make modules
make modules_install
cp arch/i386/boot/bzImage /boot/vmlinuz-new
cp /boot/

edit: then i edit lilo and run lilo
i know that would come up if i didnt mention it.

Goatdemon 12-07-2002 05:17 PM


DavidPhillips 12-07-2002 06:58 PM

sounds like it does not have support for your filesystem

I have seen this error on a root disk with the kernel not configured right

Goatdemon 12-08-2002 02:39 PM

my fs is ext3 and i enabled it and reiser fs just to be sure. (i set it to yes) i guess ill just wipe the system and start over again...

DavidPhillips 12-08-2002 03:42 PM

do you have ext2 support?

I saw something about a bad download of the kernel that caused the same problem

Goatdemon 12-09-2002 01:12 PM

i didnt see anything that said enable ext2 support, anyway i have an ext3 fs.

nxny 12-09-2002 01:29 PM

This could be a problem with your zlib. If I were you, I would try and reinstall zlib ( your gz utilities ) and try a make bzImage again.

BTW, you dont need more that one make clean and you would need a make menuconfig or make xconfig before you make dep. Is that what you intended to say in your kernel compilation steps above?

DavidPhillips 12-09-2002 01:50 PM

It's called Second extended fs support and it must be built-in

DavidPhillips 12-09-2002 02:04 PM

I do this

make mrproper
make menuconfig
make dep
make clean
make bzImage
make modules
make modules_install
cat arch/i386/boot/bzImage > /boot/vmlinuz-2.4.19-lq4
cp /boot/
ln -sf /boot/ /boot/
cp .config /boot/config-2.4.19-lq4
echo "image=/boot/vmlinuz-2.4.19-lq4" >> /etc/lilo.conf
echo " root = /dev/hda2" >> /etc/lilo.conf
echo " label = Linux-lq4" >> /etc/lilo.conf
echo " read-only" >> /etc/lilo.conf

also there is initrd which I do not have on this system, but I would add

root@slacker:/usr/src/linux-2.4.19-lq# ls /lib/modules
2.4.18/ 2.4.19-lq4/

mkinitrd /boot/initrd-2.4.19-lq4.img 2.4.19-lq4

echo " initrd = /boot/initrd-2.4.19-lq4.img" >> /etc/lilo.conf


Goatdemon 12-09-2002 10:06 PM

i totally wiped my slack drive and reinstalled with the same errors, i need to recompile to get sound! this sucks!

ill try the ext2 thing and ill add make before make bzimage.

Goatdemon 12-09-2002 10:54 PM

ok, this is pissing me off. i've recompiled my kernel numerous times but all of the sudden i keep running into a friggin wall!

with the 2.4.18 kernel i get mouse errors saying that x cannot open /dev/input/mice and that it doesn't exist. it works on the install when i choose the usb.i kernel but when i recompile to get sound, even recompile and just change sound to yes and enable my soundcard, i get that error. i did do the necessary xf86config file modifications (protical IMPS/2) (device /dev/input/mice).

with 2.4.20 i get the invalid compressed format (error=1) or kernel panic, tried to kill init.

im posting my kernelconfig files on a website ill be tinkering with soon for 2.4.18 and 2.4.20, ive got no idea what's wrong. and i did have ext2 enabled.

DavidPhillips 12-09-2002 11:33 PM

are you sure you need to recompile to get sound, I would think that you could load modules, slack comes configured with pretty much all modules built

what is the sound card

you could try to modprobe some drivers in /lib/modules/2.4.18/kernel/drivers/sound
for mine I just went and saw ac97 so I did

modprobe ac97
then modprobe sb

usually if you try to load one and there is no error it is one you can use

then you would set it up to load on boot in /etc/rc.d/rc.modules

Goatdemon 12-10-2002 02:00 PM

well i tried to do that but when i did modprobe soundcore it said no such module yadda yadda and plus my soundcard uses the chipset that is 3rd down from the top in the sound menue, ill give ya the name later... it starts with a c.... and im almost positive that it is by default set to off and not module.

All times are GMT -5. The time now is 04:50 PM.