-   Linux - General (
-   -   Intel Graphics Media Accelerator 3150 (

danielngu 05-11-2012 07:54 PM

Intel Graphics Media Accelerator 3150
I've a HP Mini 110-4102TU with the following hardware and have tried various of the latest distros:

Intel Atom dual core Processor N2600
Intel NM10 Express Chipset
Intel Graphics Media Accelerator 3150 (shared)

All of them used the Vesa rather than Intel driver.

glxinfo | grep render returned:

direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
GL_NV_conditional_render, GL_AMD_draw_buffers_blend,

I assumed that means no hardware acceleration. Just wondering if anyone has managed to get hardware acceleration with the 3150 graphics.

business_kid 05-12-2012 01:35 PM

That actually means mesa is doing the business in whatever way it can. It seems to smell AMD in there, wonder if they're involved?

lscpi -v (Please don't post it) gives you the kernel driver in use, interrupts, etc. lspci -n gives you the and you can google for that.

danielngu 11-20-2012 09:12 PM

Intel Graphics Media Accelerator 3150 (Solved)
Found a working solution, there are Cedarview deb packages. Install with Xfce, then install the Cedarview packages:

apt-get install cedarview-drm libva-cedarview-vaapi-driver cedarview-graphics-drivers

Ignore the repository, it is now in Multiverse for Ubuntu and a straight apt-get install on Linux Mint.

Prerequisite: generic kernel rather than pae.

According to Intel (

GNOME3 requires OpenGL, the Cedarview driver provides support for OpenGLES 2.0, but limited “big” OpenGL support.

All times are GMT -5. The time now is 04:51 PM.