-   Linux - General (
-   -   Intel 82845 and boot crashing (

gregorya 04-28-2004 01:44 PM

Intel 82845 and boot crashing
Hi all,

Having a series of problems with my computer. Sorry, but I'm still most definately a newbie in Linux so I might need quite simple instructions :D

I'm running a WinXP / Mandrake 10 KDE dual boot machine, with an Intel 82845 Graphics Card, a ICH4 845G/GL soundcard, and I imagine thats pretty much all that matters. If you need any more information just ask.

1) It refuses to play more than one sound at once, XMMS works fine, I can have sounds on GAIM and other applications, but not together. As far as I can see from some googling, this is because XMMS accesses the soundcard directly, whereas KDE wants everything to be routed via itself. Is that correct? If so, how can I fix the problem? I do not have this problem in Windows.

2) On boot, it often hangs, needing a reboot. It either:
a) Seems to fail to load correclty, in that when KDE starts to load it simply hangs, on a blue screen with the cursor as just a black Cross (so before it changes to a normal cursor and KDE starting to load everything, but after all of the boot in text mode)


b) Seems to fail to initialise graphics properly, in that I get about half the screen in randomly coloured horizontal lines, which change place after a time. This happens, again, after the boot bit in text is done but before KDE loads.

Are these both likely to be the same problem? What is the machine doing in between the cross being present and it beginning to load? Why does it only happen every now and again and not on every boot or none at all? I have neither of these problems in windows, so I presume its not a hardware fault.

3) I can't seem to get any form of decent graphics. To take a familiar example, Tuxracer crashes the machine, and screensavers that require opengl won't run. I can find other bits on google from others saying that they've got this card working ok (and it works in windows, natch), so its not the card. Where can I even begin to try and fix this? I downloaded the most recent linux drivers for the card from the intel website, but to no avail.

4) Finally, and fairly inconsequentially, on shutdown sometimes the machine fails to actually switch off. It gets all the way through the shutdown sequence, and even displays "Shutting Down" at the end (which you don't normally see because it goes too fast), but then stops. I get this problem in both windows and linux, is it a hardware problem, and is it fixable? As I say, no big deal, but means I have to stand there for a few minutes whilst it shuts off to make sure it does it properly.

Boy that was long. I tried googling for all of this, but failed to find anything helpful. So if you do find something relevant, then blame my poor surfing skills and not a lack of effort in trying.

Hope someone can help.



gregorya 04-29-2004 01:53 PM


sygin 06-02-2004 05:57 AM

Hi Alex,

I have the same hardware and am running Mandrake 10 Official. I have not had any problems with the graphics card
but the soundcard does give me grief with XMMS on this machine - I use Totem Media Player to play music. I have installed both
GNOME and KDE so am able to use applications from both even though I boot into GNOME.

Are you running the Official version of Mandrake or the Community Edition?

If it's the latter - upgrade to the official version.

I am still working on the sound problem though.

Good luck.

gregorya 06-02-2004 06:00 AM


Thanks for the reply.

I managed to fix the sound problem since posting this - I had to install the Arts plugin for xmms and change the output to use that.

And yeah, its been suggested elsewhere that the graphics card problems have been fixed for the official release, its downloading now.

Thanks for your reply,


predetor_isol 06-13-2004 11:52 AM


Where can I find the official release
for download, and is there any way that I can just upgrade???

gregorya 06-14-2004 01:35 AM


Originally posted by predetor_isol

Where can I find the official release
for download, and is there any way that I can just upgrade???

Firstly, you wanna make a new thread for this.

Secondly,, and yes you can. Although I'm not sure how stable it is; it worked on mine that doesn't mean it works ok on everyone's. Maybe someone else will have more idea.

Oh, and on the original thread, the upgrade sorted everything, thanks.


All times are GMT -5. The time now is 07:27 AM.