LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Installing Ttf Fonts In Suse (how-to) (https://www.linuxquestions.org/questions/linux-general-1/installing-ttf-fonts-in-suse-how-to-75230/)

Edward78 07-23-2003 12:23 PM

Installing Ttf Fonts In Suse (how-to)
 
http://www.acidfonts.com

After you downoad fonts from that or any other site, upack them all to a directory, after u do that delete all readme files and files other then those that have suffix 'ttf' or 'TTF'( at this time it would be a wise idea to burn all those downloaded fonts ( files with 'ttf' or 'TTF' extesion only ) to a cd, so that u can use them later in windows or linux).

After you have done all that, insert cd with fonts to a linux machine, open shell ( terminal ) and login as root, in shell mount cd with this comamnd:

mount /dev/cdrom - mounts cd rom device
cd /media/cdrom - changes directory to cdrom
cp *.* /usr/X11R6/lib/X11/fonts/truetype - copies all files to destination..

After you have done that issue this command to make sure that fonts were actually copied to destiantion directory above:

ls /usr/X11R6/lib/X11/fonts/truetype

Now that you made sure fonts were copied, all you need is to start font server ( which u need to install from packages i am sure it is installed by default in SuSe ) and make symbolic link in rc.d directory so that font server runs with your machine boot, and this is how we will do that:

rcxfs start

Now that server is running all u need is to make a symbolic link in rc,d directory and this is how u do it:

cd /etc/init.d/rc3.d
ln -s /usr/sbin/rcxfs S15rcxfs - starts font server at startup
ln -s /usr/sbin/rcxfs K15rcxfs - kills font server at shutdown

Ok this is just ridicalus, who is with me?

rch 07-24-2003 05:35 AM

Not me,I never had suse and would probably never use it at all.(even if I get it).

stickman 07-24-2003 08:19 AM

Have you tried using ttmkfdir to manually create fonts.scale and fonts.dir?

Franklin 07-24-2003 09:23 AM

You no longer need to run xfs font server to serve fonts locally. This appears to be a bit dated. In fact, if you're running 8.2 you should not be running xfs.

Making TTFonts available in SuSE is very easy. I created my own empty directory in /usr/X11R6/lib/X11/fonts (#mkdir myttf), opened the KDE font installer (as root) copied the fonts to that dierctory (from a CD or a windows font directory), and enabled them from withiin the KDE font installer module. After clicking "apply" all was set.

Most apps will have the fonts available to them from this, but others need additional hacks to various config files.

http://www.free-conversant.com/softedges/50

The link above is to a site with some SuSE specific How-to's regarding different font issues.

http://www.usr-local-bin.org

This link is to a site that has bleeding edge versions of Gnome apps in SuSE rpms for 8.2, plus a link to the apt directory for other SuSE distros. These are not official SuSE rpms, but I have had great success with them. In particular, with fixing the broken gnome 2.0 install. There are RPMs here that allow the correct rendering of GTK 2.0 apps in KDE in terms of both font and theme. I had better luck with the rpm updates than I did with the hacks described in the first link - YMMV.

I hope you find this useful.


All times are GMT -5. The time now is 09:08 PM.