-   Linux - General (
-   -   Installing in non-ACPI mode? (

fanoliv 04-27-2007 03:35 PM

Installing in non-ACPI mode?
Hello all,

I've been trying to install Fedora Core 6 (from DVD) or Ubuntu 7.04 (from Ubuntu Live CD) on my machine. However, I've been having problem installing it normally. Both hang very early. Fedora gave me some message "NET: Registered protocol family 2", and some stuff about PCI IRQ before that. Ubuntu doesn't show me any message, just black screen with blinking cursor.

I would like to try installing both versions in non-ACPI mode to see if that will work. Can someone please tell me if there's a way to do this. If I have to specify some command parameter or something before the installation, can you please let me know?

Thank you very much for your help.

GrapefruiTgirl 04-27-2007 03:38 PM

on the boot: prompt when you first boot the kernel add the word "noacpi" after the kernel name.
Alternately, you could disable the ACPI in the BIOS temporarily.
I suggest the first method first, and let us know what happens.

fanoliv 04-27-2007 06:46 PM

Thank you for your help. I tried with no luck, unfortunately. Disabled both in BIOS and in boot prompt, but still exactly the same error. I also tried disabling some other features like PnP, etc. But all still hang at same point. I would like to be able to figure it out though.

Is it possible and how hard would it be to get my hands on the source code for Fedora or Ubuntu? I don't really want to build it. But maybe I can read it and figure out what exactly it's doing at the point it hang?

Thank you.

GrapefruiTgirl 04-27-2007 07:01 PM

Obtaining the sourcecode for any or all parts of any Linux distro is not hard. You just have to locate and download the source code from one of the Linux Mirror servers.. Source code is also located on many Linux installation CD's and/or DVD's. Some distros actually compile on the fly when they install so you *may* already be in posession of the source code you want. As for downloading the sourcecode and going through it yourself, for an entire distro, you'd be there for 1000 years :p.
Firstly, if you're going to try getting either of them to work, on your own, you ought to start with Ubuntu, in my opinion only. It is a far less complex distro as far as I know, however I am not any sort of authority on either Fedora OR Ubuntu.

You would do well to pay attention to exactly what is going on when it hangs. When you start to install, do the install in NON-Graphical mode, so that you can see the actual text progress of the installation. This should provide a fair bit of information on the screen during install. I know Ubuntu has this option, because I have installed it before, but Fedora I am 100% unfamiliar with.
If you can do this, and get an idea where the installer is, ie: what it is doing and any error messages or text on the screen right before the hangup, then copy or write down what you see, and either post it back here, or go to the Ubuntu or Fedora Forum and search there or seek advice from a much more experienced user than myself, and one who is familiar with the Distro you are trying to install.

GrapefruiTgirl 04-27-2007 07:07 PM

Something else worth trying, would be to temporarily disable any extra fancy featured on your BIOS. Things in the BIOS which have an AUTO setting can sometimes cause small issues like this. The PCI IRQ message you got *might* indicate an IRQ conflict. Also, if you have multiple serial ports enabled or set to auto, disable that too. Basically anything unneeded, temporarily disable it.

Matir 04-29-2007 09:46 PM

Try booting the Ubuntu cd without the "quiet nosplash" options. Then you should get kernel boot messages to show where it is hanging, which will help narrow down the source of the problem.

fanoliv 04-29-2007 11:03 PM

Thank you for above suggestion. I tried without quiet splash options and I got a very similar messages from Ubuntu as from Fedora. At least now I know that they're both hanging at the same place. The messages I got is in the another thread in the Fedora forum, link below.

Now, if only I could figure out what this "NET: Registered protocol family 2" means and what exactly Linux is looking for here. But I guess I have to dig deep in the source code for that. So I'm trying to get a copy of the source for either Ubuntu or Fedora now.

Matir 04-29-2007 11:30 PM

"Registered protocol family 2" indicates that it has stuck PF2 (aka, IP v4) into the kernel's network stack. This is a good thing, IMHO.

fanoliv 04-29-2007 11:41 PM

So you mean this hang is somewhere in the kernel, and it's something to do with the network connection? board doesn't have any ethernet controller or anything like that on board, and I'm not using any PCI ethernet card or anything yet. Do you have any idea why it would be hanging in the network stack? Thank you.

Matir 04-29-2007 11:43 PM

It may not have anything to do with networking, it just seems to have stopped after that point. Does pressing numlock or capslock cause the light to change? How long have you let it sit there? Some CDs can just be very slow.

GrapefruiTgirl 04-29-2007 11:44 PM

Perhaps "noacpi nohotplug" would be an idea to try on the boot: prompt. Ubuntu 'does' use hotplug doesn't it? If it does, try without it.

All times are GMT -5. The time now is 04:31 AM.