-   Linux - General (
-   -   Installed SuSE, XP no longer boots (

Cloud 07-11-2004 02:15 PM

Installed SuSE, XP no longer boots

I installed SuSE Personal 9.1 yesterday, it all went fine and SuSE runs great. Only problem is, I can no longer boot windows (home).

When I select windows from the Grub selection screen I get:


root (hd0,0)
 Filesystem type is fat, partition type 0cx
chainloader +1

NTLDR is missing
Press any key to restart

I have already tried the fix that the suse docs suggest (can't post the url because I don't have 5 posts...)

The floppy disk method went as it said, except at the end where it came to testing the disk. It just said nothing was wrong with it, and didn't repair anything. I dont think my bios has the option to do what it says for the "easy" method.

So, I'm out of options. Some info that might be of use:


root (hd0,2)
install --stage2=/boot/grub/stage2 /boot/grub/stage1 d (hd0) /boot/grub/stage2 0x8000 (hd0,2)/boot/grub/menu.lst


# Modified by YaST2. Last modification on Sat Jul 10 13:18:30 2004

color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd0,2)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title Linux
    kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 vga=0x31a splash=silent desktop resume=/dev/hda2 showopts
    initrd (hd0,2)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    root (hd0,0)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
    root (fd0)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe
    kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 showopts ide=nodma apm=off acpi=off vga=normal noresume nosmp noapic maxcpus=0  3
    initrd (hd0,2)/boot/initrd

Any help would be much appreciated!

DavidPhillips 07-11-2004 10:29 PM

check this out..

whatever happened, it should be easy to fix with an XP cd. run fixmbr from the rescue console.

I would be sure to have a working linux boot floppy that will boot into suse first, or you'll be in the same boat with no suse.

Once xp boots from the disk and suse boots from the floppy start yast and reconfigure the boot loader from scratch, should work ok then.

Cloud 07-12-2004 11:25 AM

Thanks for the reply :)

But how do I make a suse boot disk? I tried going into YaST > create boot/rescue disk, then clicked boot disk one but it gave me an error:

Selected Image does not exist on medium

superztnt 07-12-2004 06:36 PM

I had that same problem. I am running Suse 9.0 but I think that this will work for you too.

Jason Z.

DavidPhillips 07-14-2004 12:26 AM

You might want a grub boot disk, not too hard to make and it comes in handy..

All times are GMT -5. The time now is 08:07 AM.