LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   INIT 3 not working. (https://www.linuxquestions.org/questions/linux-general-1/init-3-not-working-500124/)

waelaltaqi 11-09-2006 02:09 PM

INIT 3 not working.
 
i'm working on CentOS within run level 5 and i tried to switch to level 3 by typing:
Code:

init 3
the shell will start but is hangs up with this output:

Code:

starting anacron  [ok]
after that it sites doing nothing. any ideas? how can i check what services will start with init 3? what service starts after anacron?

Lenard 11-09-2006 03:46 PM

Press the 'Enter' key and enjoy life.

waelaltaqi 11-09-2006 06:30 PM

well, it looks like your "enter" click doesn't work . it just sits there doing nothing. i have to switch to level 6 then go back 5 ..

Lenard 11-10-2006 08:14 AM

Yes it does..........done this many times myself.

Did you open an xterm session to use the typed command init 3??? If yes then this is not a good idea.

The steps I take;

Log out of the GUI desktop back to the GUI log on screen press the three key combo of Ctrl+Alt+F1 [to F6]. Log on as root and provide the password when asked, then use the 'init 3' command a few seconds (1 or2) after the last [OK] message is displayed press the 'Enter' key.

FYI: init 6 is a reboot according to the /etc/inittab file;

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

waelaltaqi 11-10-2006 04:31 PM

what i did this time is editing the /etc/inittab to default level 3. when i want to switch to level 5 i'm typing init 5. the box is supposed to be a qmail server on a CentOS box. sometimes i need to look up for something with firefox. i've got another question regarding the qmail installtion from qmairocks.org. i'm trying to do the required patch to the tcp server the this is what i'm getting:
Code:

[root@localhost ~]# patch < /downloads/qmailrocks/patches/ucspi-tcp-0.88.errno.patch
can't find file to patch at input line 4
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
--------------------------
|diff -u ucspi-tcp-0.88.old/error.h ucspi-tcp-0.88/error.h
|--- ucspi-tcp-0.88.old/error.h 2000-03-18 09:18:20.000000000 -0600
|+++ ucspi-tcp-0.88/error.h    2003-01-08 13:39:12.000000000 -0600
--------------------------
File to patch:

what is the path for the file that i want to patch? i tried:

Code:

[root@localhost ~]# updatedb
[root@localhost ~]# locate ucspi*

but it coudn't find nothing. any ideas?

Lenard 11-10-2006 06:46 PM

I'm sorry, please explain in a bit more detail what you are doing???? I take it that you are attempting patch qmail, which was installed how?? If by rpm then patching will not work you need the source code. If you do not understand how to patch source code then maybe you should consider another approach, but as a general rule of thumb from where the source code is located you use a command like;

patch -p0 (or p1) < the_patch_file_here


All times are GMT -5. The time now is 03:32 PM.