-   Linux - General (
-   -   ifconfig eth0 up does not 'revive' eth0 (

Micro420 04-22-2006 12:28 PM

ifconfig eth0 up does not 'revive' eth0
**Figured it out. In addition to turning the NIC back 'up', I have to restart the network service.

# /etc/rc.d/network stop
# /etc/rc.d/network start

Problem solved. Lock thread please

I turn off my NIC card, eth0, by typing in the command:


ifconfig eth0 down
NIC is off, which is great. I then do:


ifconfig eth0 up
I can ping my LAN nodes, but I cannot reach anything outside the internet. Not even pinging by website name or IP address works. What else do I need to reinitialize eth0? Just trying to figure this out of curiousity.

haertig 04-22-2006 12:49 PM


Originally Posted by Micro420
I can ping my LAN nodes

This means that the NIC is working.

but I cannot reach anything outside the internet
And this could indicate that something may be amiss in DNS, gateway settings, etc.

Are you using a static IP or DHCP? On my Debian box these settings are stored in /etc/network/interfaces, but that could very well be a distro-specific location. If you're DHCP, you might try running dhclient manually (it's dhclient on Debian - I think - but other distros may use something else).

Micro420 04-22-2006 12:55 PM

Thanks for the help, haertig.

I solved my problem by simply restarting the /etc/rc.d/network service in addition to using

ifconfig eth0 up

All times are GMT -5. The time now is 04:04 PM.