LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-01-2004, 03:48 PM   #1
lobo78
Member
 
Registered: Oct 2003
Location: Wyoming
Distribution: Gentoo, Ubuntu, FreeBSD
Posts: 46

Rep: Reputation: 15
icewm theme change problem


I'm running Debian Sarge with IceWM and Rox-filer so I can have desktop icons. I had everything configured like I wanted it, but I was looking at different themes. I opened up a program called icepref and used it to change the theme from a default one called icedesert to one I downloaded (axxrom 1.3). When I did, it messed up all my menus and Eterm will not go transparent anymore.

The menus all show a couple of dots or periods now instead of the name of the submenu or program. Any idea what happened and how I can return it to its original state? I don't think it is a system wide problem, because I opened icewm in root, and the menu was the same as before, it is just with my normal user. I tried overwriting the preferences file with a backup, but it didn't change anything. Thanks for any help you can give.

One more thing, some of the themes will not show the clock at the bottom right of the taskbar and some will, is there an option somewhere I need to select for these themes to show it?
 
Old 04-01-2004, 06:28 PM   #2
wiBo
Member
 
Registered: Aug 2003
Location: Saint-Georges de Beauce
Distribution: Gentoo soon..
Posts: 193

Rep: Reputation: 30
In your menu, you did not have a Themes section?

Like that:


Last edited by wiBo; 04-01-2004 at 06:30 PM.
 
Old 04-02-2004, 01:24 AM   #3
lobo78
Member
 
Registered: Oct 2003
Location: Wyoming
Distribution: Gentoo, Ubuntu, FreeBSD
Posts: 46

Original Poster
Rep: Reputation: 15
Yes, I can tell everything is still in the menus because the icons are still there. Here is a screenshot as an example:



Notice also that the open programs on the taskbar also have icons, but no text. This happens for most themes, but there are a certain few that work correctly. Any ideas how to fix this? Thanks.
 
Old 04-02-2004, 04:41 PM   #4
wiBo
Member
 
Registered: Aug 2003
Location: Saint-Georges de Beauce
Distribution: Gentoo soon..
Posts: 193

Rep: Reputation: 30
OMG.. mhm you will have to change your themes in the ICEWM's config files...

I don't know which path,, sorry

check in /home/your_user/.icewm
 
Old 04-02-2004, 06:10 PM   #5
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
Looks like a font problem, to me.

I haven't used ICE in a while, though.

--Shade
 
Old 04-02-2004, 07:57 PM   #6
lobo78
Member
 
Registered: Oct 2003
Location: Wyoming
Distribution: Gentoo, Ubuntu, FreeBSD
Posts: 46

Original Poster
Rep: Reputation: 15
I asked elsewhere and someone else also thinks it is a font problem. I am just not sure how to troubleshoot this. I've tried doing a dpkg-reconfigure on icewm and icewm-common, but it did nothing. How do I see what fonts each theme needs, and where do I go to get them? Any ideas would be appreciated.
 
Old 04-02-2004, 09:35 PM   #7
LSA
Member
 
Registered: Dec 2003
Distribution: Slackware 10
Posts: 45

Rep: Reputation: 15
Quote:
Originally posted by lobo78
I asked elsewhere and someone else also thinks it is a font problem. I am just not sure how to troubleshoot this. I've tried doing a dpkg-reconfigure on icewm and icewm-common, but it did nothing. How do I see what fonts each theme needs, and where do I go to get them? Any ideas would be appreciated.
Usually near the end of the default.theme file for the theme (In the themes folder)

Good luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
(What's your) Favourite icewm theme(s) ? samael26 Linux - Software 1 06-08-2005 07:36 PM
Icewm SilverXP theme trouble newinlinux Linux - Software 1 08-08-2004 10:41 AM
Webmin Theme change problem suyixiang Linux - Newbie 1 04-23-2004 06:27 AM
icewm theme problem ludwig W Linux - General 6 01-15-2004 04:57 AM
icewm and default theme j_developer Linux - General 2 09-13-2002 05:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration