-   Linux - General (
-   -   i tried resizeing my logical volume, (

rahman.athiq 07-12-2007 01:43 AM

i tried resizeing my logical volume,
I tried resizeing the logical volume..! after resizeing it i get the following error.
It ask me to repair the filesystem..! after running the fsck -y /dev/mpper/vg00-optlv
fsck 1.35 (28-Feb-2004)
e2fsck 1.35 (28-feb-2004)
The fileystem size ( according to the superblock) is 2596864 blocks.
The physical size of the device is 25772288 blocks
Either the superblock or the partition table is likely to be corrupt!

can anyone please help me in this issue..! i have very critical data on this..! so please help..! i will appreciate your help..!
kernel image--kernel /vmlinuz-2.6.9-5.ELsmp.


Mara 07-13-2007 04:18 PM

Moved: This thread is more suitable in Linux-General and has been moved accordingly to help your thread/question get the exposure it deserves.

How big was the resize? I mean, is the size difference explainable? before attempting everything, backup the whole partition (you should have done it before resizing) using dd to copy the whole
dd if=/dev/mpper/vg00-optlv of=/some/file
When having the copy you can work on it (the copy) to find the reason and recover your data. If possible, do not use the disk the corrupted partition is. Copy it and use a different disk for operations on it, because there may be more data useful for recovery that is not copied by the dd operation.

You may try to mount the copy file, just like a normal partition. Try it.

All times are GMT -5. The time now is 06:19 AM.