-   Linux - General (
-   -   I/O error deleting file, file permissions represented as ????????? (

phillinux 01-16-2013 12:04 PM

I/O error deleting file, file permissions represented as ?????????
I couldn't view the contents of a folder on the Windows data partition of my Ubuntu machine. The GUI reported the folder as empty. I opened a terminal (console) and navigated to the offending folder and found all my files and folders as well as what seems to be a corrupted file. The files permissions, ownership, size and access date are all represented by question marks. (screen output follows)

-rw------- 2 phil phil 24427 Nov 9 09:51 Variety-order.odt
-????????? ? ? ? ? ? Variety-order.txt
-rw------- 1 phil phil 818 Nov 13 10:26 Variety-order.txt~

when I tried to remove the file even with the -f flag, I got the following error:

rm: cannot remove `Variety-order.txt': Input/output error

Anyone have any ideas how I can get rid of this file or otherwise resolve this issue?


unSpawn 01-16-2013 12:37 PM

IMHO if you have problems that relate to microsoft products you best try and fix them using the tools microsoft provides.

phillinux 01-16-2013 01:48 PM

problem solved
I didn't realizee the problem was on the windows side. Probably a file locking error. I'm in Ubuntu 90% of the time but need to access my files from both sides so I created a data partition (ntfs volume).

I was able to log into widows and delete the offending file; all is visible once again.

All times are GMT -5. The time now is 08:04 AM.