LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   I get mount: /dev/cdrom: can't read superblock, How to fix? (https://www.linuxquestions.org/questions/linux-general-1/i-get-mount-dev-cdrom-cant-read-superblock-how-to-fix-84070/)

zLinuxz 08-21-2003 02:10 AM

I get mount: /dev/cdrom: can't read superblock, How to fix?
 
Hi guys, I know it must be some dumb mistake I did, but when I'm trying to mount my drives, they say

mount: /dev/cdrom: can't read superblock

I just compiled my new 2.4.21 kernel, how can I fix this?

thanks for the help, :)

kev82 08-21-2003 03:33 AM

have you got isofs built into the kernel or as a module, if its a module try modprobing it before you mount, also might be worth a check where /dev/cdrom points to

zLinuxz 08-21-2003 03:40 AM

ehmm, well, it works with my previous kernel, why won't it work with this one?, did I forget something, or what?

I'll check the isofs thing, thanks.

zLinuxz 08-21-2003 03:44 AM

yes, ISO file system for CD-ROM's is built into the kernel.

what can I do next?, need more help, thank you

kev82 08-21-2003 04:03 AM

does the output of cat /proc/filesystems contain either isofs or iso9660

zLinuxz 08-21-2003 10:59 AM

OKay, I did that command, and YES, it is in there man. Thanks, any other thoughts?


cat /proc/filesystems
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev tmpfs
nodev shm
nodev pipefs
nodev binfmt_misc
ext3
ext2
cramfs
nodev ramfs
minix
msdos
msdos
vfat
iso9660
vxfs
nodev nfs
ntfs
efs
nodev autofs
nodev devpts
nodev usbdevfs
nodev usbfs

kev82 08-21-2003 11:03 AM

what does your /etc/fstab say? specifically the line with /mnt/cdrom in it?

zLinuxz 08-21-2003 11:15 AM

here's the Fstab:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0

Mathieu 08-21-2003 11:21 AM

zLinuxz,
Are you getting the same errors you were getting when you posted this thread ?
...... just kidding :p

(For those you want to understand this joke, refer to this thread.
http://www.linuxquestions.org/questi...threadid=84028
)

I had a similar problem where my two NICs were switched when I recompiled my kernel.
Perhaps something similar occurred with your CD-ROMs.

Did you check the /dev/cdrom and the /dev/cdrom1 soft links to make sure they point to the correct devices.

zLinuxz 08-21-2003 11:27 AM

hey, hehhe,
yes, I did, and I even tried mounting them directly from /dev to /mnt, and still I get the Can't read SuperBlock error....it's frustating, :(

zLinuxz

kev82 08-21-2003 11:38 AM

i have pretty much no expertise with scsi so i'll end my contribution to this thread with this silly question: have you tried other cd's in the drive, cos it could be scratched cd?

Shade 08-21-2003 02:07 PM

Hmm... Try it by not using the symlinks...

Find out if the cdrom drive is hdc, hdd, hde, whatever...

mount -t iso9660 /dev/hdc /mnt/cdrom

Are you getting specifically, "can't read superblock"
or is it the usual
"bad superblock, too many filesystems mounted, or wrong filesystem" etc... ?

You're sure the drive is OK, right? If not, try booting from a bootable cd and see what happens.

-Shade

Drone4four 06-18-2008 02:42 AM

I'm trying to mount my DVD drive to /dvdrom. I tried the commands prescribed to zLinuxz. Here is the error message I get:

Code:

bash-3.1# mkdir /dvdrom
bash-3.1# mount -t iso9660 /dev/hdc /dvdrom
mount: block device /dev/hdc is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

And here is dmesg |tail as the above error message suggests:

Code:

bash-3.1# dmesg | tail
hdc: command error: status=0x51 { DriveReady SeekComplete Error }
hdc: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
ide: failed opcode was: unknown
ATAPI device hdc:
  Error: Illegal request -- (Sense key=0x05)
  Illegal mode for this track or incompatible medium -- (asc=0x64, ascq=0x00)
  The failed "Read 10" packet command was:
  "28 00 00 00 00 10 00 00 01 00 00 00 00 00 00 00 "
end_request: I/O error, dev hdc, sector 64
isofs_fill_super: bread failed, dev=hdc, iso_blknum=16, block=16
bash-3.1# exit
exit
bash-3.1$

Here is my fstab:

Code:

/dev/hda5        swap            swap        defaults        0  0
/dev/hda1        /                ext3        defaults        1  1
/dev/hdb1        /home/ntfs      ntfs-3g    umask=000        1  0
/dev/cdrom      /mnt/cdrom      auto        noauto,owner,ro  0  0
/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0
tmpfs            /dev/shm        tmpfs      defaults        0  0

Here are the contents of /mnt/cdrom:

Code:

bash-3.1# cd /mnt/cdrom
bash-3.1# ls
bash-3.1# exit
exit
bash-3.1$

Here is mount if interested:

Code:

bash-3.1# mount
/dev/hda1 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hdb1 on /home/ntfs type fuseblk (rw,nosuid,nodev,noatime,allow_other,blksize=4096)
tmpfs on /dev/shm type tmpfs (rw)
bash-3.1#

I installed a new PSU, which means I was playing with the power cord connected to the DVD rom bay, however the bay opens and closes easily, allowing me to insert and audio disk.

I am btw running Slackware 12.1 stock kernel.


All times are GMT -5. The time now is 11:31 AM.