-   Linux - General (
-   -   I can't recover any operating systems from an OpenSuse LiveCD (

skykooler 10-05-2011 01:10 PM

I can't recover any operating systems from an OpenSuse LiveCD
I don't know if this goes here, so sorry if I posted in the wrong forum. I have a hepta-boot system (Windows 7, OSX, Mint, Kubuntu, Meego, Suse and Android) on my netbook. The way it worked was that the Chameleon bootloader would boot either Windows, Mac or Grub, which could then boot everything else. Anyway, I accidentally installed Grub over Chameleon, and tried to re-install Chameleon from within Linux. I messed up somewhere so it said "boot0: error" when I tried to boot. The only liveCD (or rather, liveUSB) I had was my OpenSuse one. I booted that and tried to chroot into my Mint install, only to find that Suse doesn't recognize any of the partitions on my hard drive. Furthermore, I can install Unetbootin within Suse, but it won't recognize any flash drives I plug in, so I can't just install Puppy or something to a flash drive. grub-install gives me the error that "/dev/loop0 does not have any corresponding BIOS drive." I tried installing Suse to another flash drive, but even though I selected that drive for bootloader installation it somehow still installed Grub stage 0 to the HD, and it doesn't find the next stage (I get error 22).
Any ideas how I can boot up? I do not have an external optical drive I can use, or another computer. (I am writing this from the Suse livecd.)

onebuck 10-05-2011 06:29 PM

Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.

All times are GMT -5. The time now is 11:29 PM.