LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-26-2007, 03:38 AM   #1
shura
LQ Newbie
 
Registered: Apr 2007
Location: Moscow
Posts: 3

Rep: Reputation: 0
I can't boot my RedHat with noexec=off automatically


Hi there!
I need boot my RedHat system with noexec=off parameter. I added noexec=off to kernel string in grub.conf, as shown in manual, but it didn't give any result - when I rebooted the computer, this parameter wasn't active (it not exist in /proc/cmdline and my computer works not properly).
When I try to reboot interactively, (press 'e' key during rebooting, for example), I show kernel string without noexec=off, so if I add this parameter, and continue rebooting, it appears in /proc/cmdline, and everything in my computer works properly.
Can someone help me? Thank you in advance!
 
Old 04-26-2007, 09:42 PM   #2
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 76
Perhaps there is more than one kernel in your grub configuration file, and you got the wrong one. Perhaps you have more than one grub accidentally installed and you got the wrong one’s configuration file. In any case, it wouldn’t hurt if you posted your grub.conf (or menu.lst).
 
Old 04-27-2007, 03:10 AM   #3
shura
LQ Newbie
 
Registered: Apr 2007
Location: Moscow
Posts: 3

Original Poster
Rep: Reputation: 0
here is my grub.conf

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,2)
# kernel /boot/vmlinuz-version ro root=/dev/md1
# initrd /boot/initrd-version.img
#boot=/dev/sda3
default=0
timeout=5
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux AS (2.6.9-42.ELsmp)
root (hd0,2)
kernel /boot/vmlinuz-2.6.9-42.ELsmp ro root=/dev/md1 quiet noexec=off
initrd /boot/initrd-2.6.9-42.ELsmp.img

After rebooting flag noexec=off doesn't appear

# cat /proc/cmdline
ro root=/dev/md1 rhgb quiet
 
Old 04-27-2007, 01:59 PM   #4
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 76
grub.conf:kernel /boot/vmlinuz-2.6.9-42.ELsmp ro root=/dev/md1 quiet noexec=off
cmdline:ro root=/dev/md1 rhgb quiet
What strikes me (besides the absence of “noexec=off” from /proc/cmdline) is the presence of “rhgb” (red hat’s grub boot?).

I have a feeling that there is another instance of GRUB somewhere on your computer (and this is what’s being booted).

Of course I could be completely off the mark .
 
Old 04-28-2007, 02:03 AM   #5
shura
LQ Newbie
 
Registered: Apr 2007
Location: Moscow
Posts: 3

Original Poster
Rep: Reputation: 0
I have some feeling, about another grub But i have no idea, where it may locate...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
noexec on /tmp but still stefaandk Linux - Security 10 03-05-2007 07:02 AM
automounting usb drive with -noexec off Rohan_mk1 Linux - Software 0 12-13-2006 10:53 AM
what is nosuid, noexec & nodevel?? coolblue Linux - Newbie 3 03-14-2005 11:58 AM
reinstall --> /tmp & noexec issue Fuel Slackware 1 11-30-2004 11:43 PM
NOEXEC, NOSUID, READONLY in Linux CarlosSunden Linux - General 0 05-05-2004 03:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration