LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-13-2012, 12:08 PM   #1
AndrewJH
LQ Newbie
 
Registered: Apr 2012
Location: Canada
Distribution: openSUSE 12.1
Posts: 13

Rep: Reputation: Disabled
Question How to turn off Kaffeine subtitles.


I want to get an animated kde background. Instead of doing what everyone does, I decided to use Kaffeine. I gave it special properties and forced the window type to be desktop, and I've set my video to loop. Everything looks awesome except that as soon as the video is done playing, it shows the location of the file that it's playing. It then fades away, then it's fine. I think these are subtitles or "OSD", but anyway, I want to turn them off. I have edited /home/andrew/.kde4/share/apps/kaffeine/xine.config.txt in all these areas:

subtitle size
{ tiny small normal large very large huge }, default: 1
subtitles.separate.subtitle_size:tiny

subtitle vertical offset
numeric, default: 0
subtitles.separate.vertical_offset:768


and also

use unscaled OSD if possible
bool, default: 0
subtitles.separate.use_unscaled_osd:0

default duration of subtitle display in seconds
numeric, default: 0
subtitles.separate.timeout:0


So what am I doing wrong? If I leave the "#" symbol there it gets reset when I log out and in, so I took that away, as it said so:

Entries which are still set to their default values are commented out.
Remove the '#' at the beginning of the line, if you want to change them.

Is there another program I can use? I'm using openSUSE 12.1 KDE.
 
Old 04-15-2012, 09:22 PM   #2
AndrewJH
LQ Newbie
 
Registered: Apr 2012
Location: Canada
Distribution: openSUSE 12.1
Posts: 13

Original Poster
Rep: Reputation: Disabled
Sorry for posting a reply, but for some reason I was not able to edit my post. Anyway, I just wanted to add that I found this forum, so I'm going to try that. I would still prefer a looping video, though, so any replies would be appreciated. I also have some more questions: I use VLC as my default media player, and I'm wondering if I can have two configurations of VLC, one for animated desktop, and the other for regular video playing. I don't want to have to watch every video fullscreen, which I why I decided to use a different program, Kaffeine, for animated desktop, and VLC for regular video playing.
 
Old 04-16-2012, 08:42 AM   #3
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,055

Rep: Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078
Have you tried using mplayer for your background? It's been a while since I've messed with video backgrounds but I seem to remember that worked OK and it has more options than Kaffeine.
 
Old 04-16-2012, 07:42 PM   #4
AndrewJH
LQ Newbie
 
Registered: Apr 2012
Location: Canada
Distribution: openSUSE 12.1
Posts: 13

Original Poster
Rep: Reputation: Disabled
Thanks for the reply. About Mplayer, I installed it, and it simply wouldn't open up anything. The same for SMplayer (because it is just a backend, I think). What other packages do I need to install to make Mplayer work? I know that before I used the program electricsheep for my background in Gnome, which worked fine and used Mplayer. I haven't tried installing electricsheep in openSUSE yet, and I'm not even sure if I can, but I'll try.

Also, another question, is it possible to set Kaffeine to loop video automatically and play a certain file whenever it is opened? Is there something that I can configure in my autostart configuration? I know this is a lot to ask, and I'm fine opening up my file every time if there's no way.

I'll let you know how my experience with xscreensaver is.
 
Old 04-16-2012, 07:53 PM   #5
AndrewJH
LQ Newbie
 
Registered: Apr 2012
Location: Canada
Distribution: openSUSE 12.1
Posts: 13

Original Poster
Rep: Reputation: Disabled
Thanks for the reply. About Mplayer, I installed it, and it simply wouldn't open up anything. The same for SMplayer (because it is just a backend, I think). What other packages do I need to install to make Mplayer work? I know that before I used the program electricsheep for my background in Gnome, which worked fine and used Mplayer. I haven't tried installing electricsheep in openSUSE yet, and I'm not even sure if I can, but I'll try.

Also, another question, is it possible to set Kaffeine to loop video automatically and play a certain file whenever it is opened? Is there something that I can configure in my autostart configuration? I know this is a lot to ask, and I'm fine opening up my file every time if there's no way.

I'll let you know how my experience with xscreensaver is.
 
Old 04-17-2012, 05:03 AM   #6
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,055

Rep: Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078
I'm afraid I don't now enough about SuSe ro know whether just onstalling mplayer is enough.
To run mplayer you meed to do so from a terminal and specify the file to open, e.g. "mplayer movie.avi". I was under the impression that you were using an option for your background which was called something like "use a program to draw my background" which allowsyou to specify a program and command-line parameters for it.
Unfortunately can't install KDE at the moment so I'm going on memory.
Edit: I just managed to run KDE in a virtual machine and it seems the option isn't there so perhaps it was a KDE3 only thing to allow any program to draw the desktop.

Last edited by 273; 04-17-2012 at 05:31 AM.
 
Old 04-17-2012, 09:41 AM   #7
AndrewJH
LQ Newbie
 
Registered: Apr 2012
Location: Canada
Distribution: openSUSE 12.1
Posts: 13

Original Poster
Rep: Reputation: Disabled
Thanks so much for helping me with Mplayer. I did what you said, and got it running, and it didn't show the annoying file name thing when it opened! I'm just going to go find all those tutorials about Mplayer. Thanks so much! I don't know how this would work in Autostart, though, it would probably be a script, right?
 
Old 04-17-2012, 09:47 AM   #8
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,055

Rep: Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078
Glad I could help.
I'm not sure how you're using it but my guess would be that, yes, you could put a script with the commands you're using in autostart.
 
Old 04-17-2012, 10:00 AM   #9
AndrewJH
LQ Newbie
 
Registered: Apr 2012
Location: Canada
Distribution: openSUSE 12.1
Posts: 13

Original Poster
Rep: Reputation: Disabled
Sorry for not specifying, but what I mentioned in the beginning about how to make it the background was by right clicking the Kaffeine title>Advanced>Special Application Settings> and then I forced it to not take focus, stay in the background, without borders, fullscreen, on all desktops, and forced the window type to Desktop.
 
Old 04-17-2012, 10:04 AM   #10
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,055

Rep: Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078
Ah, they must be new setting used in KDE4.
I'm not sure whether mplayer will work with them or not, but there ought to be some way to do it.
 
Old 04-17-2012, 10:05 PM   #11
AndrewJH
LQ Newbie
 
Registered: Apr 2012
Location: Canada
Distribution: openSUSE 12.1
Posts: 13

Original Poster
Rep: Reputation: Disabled
OK, so I've edited mplayer's default options to include looping, and this is the command that I put in Autostart: "mplayer -fs video.wmv". After putting it there, then logging out and in, I couldn't launch any applications or do anything at all. I logged out, then in as root and deleted the the autostart script, then all was well. It had the option in Autostart to "create as symlink", which was checked, so maybe that might have had something to do with it.

Anyway, Mplayer is working great!

---------- Post added 04-17-12 at 09:06 PM ----------

OK, so I've edited mplayer's default options to include looping, and this is the command that I put in Autostart: "mplayer -fs video.wmv". After putting it there, then logging out and in, I couldn't launch any applications or do anything at all. I logged out, then in as root and deleted the the autostart script, then all was well. It had the option in Autostart to "create as symlink", which was checked, so maybe that might have had something to do with it.

Anyway, Mplayer is working great!
 
Old 04-18-2012, 01:37 PM   #12
AndrewJH
LQ Newbie
 
Registered: Apr 2012
Location: Canada
Distribution: openSUSE 12.1
Posts: 13

Original Poster
Rep: Reputation: Disabled
I tried three additional things: Adding "mplayer -fs video.wmv" as a program instead of a script, which didn't work, even after I made it executable. I also tried just simply leaving it running when I logged out to see if it would get restored when I logged back in. That didn't work either, as programs are just restored, but not in the state that they were in last (I just got an empty terminal). Then I tried adding the script, but unchecking "create as symlink". It wouldn't even let me create the script, because of this problem: Unable to create io-slave: klauncher said: Unknown protocol. But it still put something down there, so I logged out and in again. When I logged back in, the script had mysteriously disappeared. I'm kinda out of ideas.
 
Old 04-19-2012, 10:32 AM   #13
AndrewJH
LQ Newbie
 
Registered: Apr 2012
Location: Canada
Distribution: openSUSE 12.1
Posts: 13

Original Poster
Rep: Reputation: Disabled
I just figured it out. I added a .desktop icon on my desktop, and all I have to do is click on it to start my animated wallpaper. Here's the content of it (I've also added fullscreen to default options in Mplayer):


[Desktop Entry]
Version=1.0
Encoding=UTF-8
Type=Application
Name=Animated Wallpaper
Comment=
Categories=Application;
Exec=mplayer Sureal.wmv
Icon=
Terminal=true
StartupNotify=false

I found out how to do this in this thread: http://www.linuxquestions.org/questi...in-kde-663740/

I'm going to mark this as solved.
 
Old 04-19-2012, 11:10 AM   #14
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,055

Rep: Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078
Glad you figured it out, I might have a go at it myself some time when I have KDE installed.
 
Old 04-20-2012, 09:18 AM   #15
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,055

Rep: Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078Reputation: 2078
I forgot to mention, if you're still looking, that for some added fun you could install aalib and use the option "-vo aa" to mplayer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Add Subtitles to Divx file with Option to turn it On or Off RedNeck-LQ Linux - General 2 02-12-2011 06:33 PM
how to turn permanently turn on laptop fan?;] blorpton Linux - Laptop and Netbook 6 01-11-2010 12:48 PM
My CnMBook Manual page 5 shows how to turn off on desk top, but how do I turn on? salmagundi Linux - Newbie 2 04-04-2009 03:46 PM
Arabic subtitles in Kaffeine-xine azazel11998 Ubuntu 0 04-26-2007 05:16 PM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 09:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration