LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 02-21-2003, 01:33 PM   #1
jkraeger
LQ Newbie
 
Registered: Feb 2003
Posts: 4

Rep: Reputation: 0
How to stop screen from going blank


This is a stupid question but how do I prevent the x screen from going blank after the system sits idle for a while. I tried a bunch of things and none of them worked. Is this a power save feature or just a screen saver? Could it being on a KVM switch screw things up?
 
Old 02-21-2003, 03:56 PM   #2
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
It's most likely a power management feature. Additionally, check your screen saver settings to see if there's a timeout feature that will make your screen go blank after so many minutes. I know there's a setting for Gnome screensavers that you can set to make it go blank.
 
Old 02-21-2003, 04:03 PM   #3
boreo
Member
 
Registered: Feb 2003
Location: Dominican Republic
Distribution: Slackware, FreeBSD, RedHat
Posts: 326

Rep: Reputation: 30
Yea is maybe a screensaver, mines is setup to go blank in 60 minutes, so maybe thats your problem.. KDE Menu --- Preferences--- Look & feel --- Screensaver.. I hope this solves your problem.
 
Old 02-21-2003, 05:01 PM   #4
joesbox
Member
 
Registered: Feb 2003
Location: hampton va
Distribution: ubuntu
Posts: 502

Rep: Reputation: 30
i personally use xscreensaver for my .... uh screensaver. if you don't know how to run it go to terminal and type <xscreensaver> and a GUI will pop up. click on settings and go to advanced tab. there will be a setting to shut off the energy settings.
if you ever want to get this back then type <xscreensaver-command -demo> and this will bring back the GUI.
hope this helps
 
Old 02-21-2003, 05:48 PM   #5
Elijah
Member
 
Registered: Feb 2003
Location: Philippines
Distribution: Debian, Mandrake, Redhat
Posts: 90

Rep: Reputation: 15
care of Slapnut from JL:

--------------------
Do this as root to disable the sleep mode... etc.
/sbin/chkconfig --level 123456 apmd off
<edit> Either reboot to make changes or:
/etc/rc.d/init.d/apmd stop </edit>
If it doesn't help then turn it back on with:
chkconfig --level 345 apmd on.
<edit> Either reboot to make changes or:
/etc/rc.d/init.d/apmd start </edit>
--------------------
 
Old 02-21-2003, 09:51 PM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Possibly the setterm command is what your looking for.

man setterm for more details.
 
Old 02-22-2003, 12:33 PM   #7
TexasDex
Member
 
Registered: Feb 2003
Location: The Attic. Nowhere near Texas.
Distribution: Gentoo, Kubuntu, formerly LFS, SuSE, and RedHat
Posts: 133

Rep: Reputation: 15
Also you should check the BIOS. Often the BIOS has an option for power saving which overrides software settings.
 
Old 02-22-2003, 11:35 PM   #8
Daemonfly
Member
 
Registered: Feb 2003
Distribution: Gentoo
Posts: 63

Rep: Reputation: 15
I had a problem with this when installing Gentoo - system would never come back from the blank screen. Had to put a weight on the shift key while compiling everything to keep the screen up

BIOS settings had no effect, and this is deffinately not a screensaver, etc...

I'll have to note some of the solutions above.
 
Old 02-23-2003, 01:24 AM   #9
Elijah
Member
 
Registered: Feb 2003
Location: Philippines
Distribution: Debian, Mandrake, Redhat
Posts: 90

Rep: Reputation: 15
I believe trickykid has a better solution for this one, setterm.

in the man page: -powersave off
 
Old 02-25-2003, 09:05 PM   #10
MikeVx
LQ Newbie
 
Registered: Feb 2003
Posts: 21

Rep: Reputation: 0
Cool

Some versions of Slackware, others may or may not do this, have a command in
/etc.rc.d/rc.M
in the form
/bin/setterm -blank 15

The most recent version of X I installed (4.2.1) does not over-ride this, so if I don't use it for a while, the screen blanks. FInd the equivalent file in your system boot chain and either adjust it or block it from executing, as suits your purpose.

Last edited by MikeVx; 02-25-2003 at 09:06 PM.
 
Old 02-26-2003, 10:36 PM   #11
joewalp
LQ Newbie
 
Registered: Feb 2003
Distribution: RH8
Posts: 1

Rep: Reputation: 0
I use a utility called xset to disable the dpms screen saver and to change the mouse tracking speed.

Realize that my RH8 installation is a little unconventional for a workstation in that (a) I boot to the console and start X using the startx script and (b) I use IceWM rather than Gnome or KDE desktop.

Here's the relevant excerpt from the ~/.Xclients script (called by startx).

# Change the mouse tracking speed.
xset m 4 2
# Disable the screensaver.
xset s off
# Disable Energy Star.
xset -dpms
# Start the window manager.
exec /usr/bin/icewm || exec xterm -fg red

I don't know how you'd go about using this with XDM.

Last edited by joewalp; 02-27-2003 at 07:44 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.0 Blank screen instead of login in screen damoncf Linux - Distributions 4 02-24-2007 08:49 PM
Blank Screen Lintux Slackware 26 03-02-2005 07:41 AM
Blank screen even before BIOS screen on boot josce Linux - Laptop and Netbook 3 01-04-2005 08:27 AM
Blank screen after initial install screen? CRCool75 Linux - Newbie 2 11-16-2004 09:32 PM
Blank screen - screen saver ??? cstehle Linux - Newbie 8 03-13-2002 09:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration