LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   How to stop screen from going blank (https://www.linuxquestions.org/questions/linux-general-1/how-to-stop-screen-from-going-blank-46535/)

jkraeger 02-21-2003 01:33 PM

How to stop screen from going blank
 
This is a stupid question but how do I prevent the x screen from going blank after the system sits idle for a while. I tried a bunch of things and none of them worked. Is this a power save feature or just a screen saver? Could it being on a KVM switch screw things up?

Texicle 02-21-2003 03:56 PM

It's most likely a power management feature. Additionally, check your screen saver settings to see if there's a timeout feature that will make your screen go blank after so many minutes. I know there's a setting for Gnome screensavers that you can set to make it go blank.

boreo 02-21-2003 04:03 PM

Yea is maybe a screensaver, mines is setup to go blank in 60 minutes, so maybe thats your problem.. KDE Menu --- Preferences--- Look & feel --- Screensaver.. I hope this solves your problem.

joesbox 02-21-2003 05:01 PM

i personally use xscreensaver for my .... uh screensaver. if you don't know how to run it go to terminal and type <xscreensaver> and a GUI will pop up. click on settings and go to advanced tab. there will be a setting to shut off the energy settings.
if you ever want to get this back then type <xscreensaver-command -demo> and this will bring back the GUI.
hope this helps

Elijah 02-21-2003 05:48 PM

care of Slapnut from JL:

--------------------
Do this as root to disable the sleep mode... etc.
/sbin/chkconfig --level 123456 apmd off
<edit> Either reboot to make changes or:
/etc/rc.d/init.d/apmd stop </edit>
If it doesn't help then turn it back on with:
chkconfig --level 345 apmd on.
<edit> Either reboot to make changes or:
/etc/rc.d/init.d/apmd start </edit>
--------------------

trickykid 02-21-2003 09:51 PM

Possibly the setterm command is what your looking for.

man setterm for more details.

TexasDex 02-22-2003 12:33 PM

Also you should check the BIOS. Often the BIOS has an option for power saving which overrides software settings.

Daemonfly 02-22-2003 11:35 PM

I had a problem with this when installing Gentoo - system would never come back from the blank screen. Had to put a weight on the shift key while compiling everything to keep the screen up :D

BIOS settings had no effect, and this is deffinately not a screensaver, etc...

I'll have to note some of the solutions above. :)

Elijah 02-23-2003 01:24 AM

I believe trickykid has a better solution for this one, setterm.

in the man page: -powersave off

MikeVx 02-25-2003 09:05 PM

Some versions of Slackware, others may or may not do this, have a command in
/etc.rc.d/rc.M
in the form
/bin/setterm -blank 15

The most recent version of X I installed (4.2.1) does not over-ride this, so if I don't use it for a while, the screen blanks. FInd the equivalent file in your system boot chain and either adjust it or block it from executing, as suits your purpose.

joewalp 02-26-2003 10:36 PM

I use a utility called xset to disable the dpms screen saver and to change the mouse tracking speed.

Realize that my RH8 installation is a little unconventional for a workstation in that (a) I boot to the console and start X using the startx script and (b) I use IceWM rather than Gnome or KDE desktop.

Here's the relevant excerpt from the ~/.Xclients script (called by startx).

# Change the mouse tracking speed.
xset m 4 2
# Disable the screensaver.
xset s off
# Disable Energy Star.
xset -dpms
# Start the window manager.
exec /usr/bin/icewm || exec xterm -fg red

I don't know how you'd go about using this with XDM.


All times are GMT -5. The time now is 02:04 AM.