LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 12-21-2017, 07:11 PM   #1
dwhb
Member
 
Registered: Jul 2012
Location: Down Under
Distribution: Mint 17 Qiana KDE
Posts: 87

Rep: Reputation: Disabled
How to stop Kontacts autostart on login


Hi

It never happened until recently. Kontact started up automatically every time Mint 18.2 KDE starts.
Autostart under System Settings allows you to add apps to startup but not to stop.

Please help. Thanks in advance.

Last edited by dwhb; 12-21-2017 at 07:12 PM. Reason: spelling
 
Old 12-21-2017, 10:45 PM   #2
Habitual
LQ 5k Club
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: High Sierra
Posts: 9,058
Blog Entries: 37

Rep: Reputation: Disabled
If the startup items doesn't reveal the culprit, open a terminal and issue
Code:
grep -irl kontact ~/.config/autostart/*
and paste the result(s) here.
One of them is your target for deletion.
 
Old 12-22-2017, 01:48 AM   #3
dwhb
Member
 
Registered: Jul 2012
Location: Down Under
Distribution: Mint 17 Qiana KDE
Posts: 87

Original Poster
Rep: Reputation: Disabled
This is the result I got after copy&paste your suggested code:

grep: /home/daisyb/.config/autostart/*: No such file or directory
 
Old 12-22-2017, 07:08 AM   #4
Habitual
LQ 5k Club
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: High Sierra
Posts: 9,058
Blog Entries: 37

Rep: Reputation: Disabled
OK then, in a terminal, issue
Code:
grep Exec /home/daisyb/.config/autostart/*.desktop
and you should see "hits" as every .desktop entry has an Exec= line, AFAIK
Kontact should stand right out.

If that fails, we'll look for the autostart directory using in terminal,
Code:
find .  -name autostart -type d
Is it listed in startup programs? You can disable entries, I believe by removing a checkmark for the item.
 
Old 12-22-2017, 07:13 AM   #5
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,492
Blog Entries: 3

Rep: Reputation: 426Reputation: 426Reputation: 426Reputation: 426Reputation: 426
sure it isnt ~/.kde/Autostart
 
Old 12-22-2017, 08:37 AM   #6
Habitual
LQ 5k Club
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: High Sierra
Posts: 9,058
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by Drakeo View Post
sure it isnt ~/.kde/Autostart
KDE is a gray area for me. It's gray and I'm in the area.

And yes, it may very well be there.

Thanks!
 
Old 12-22-2017, 07:24 PM   #7
dwhb
Member
 
Registered: Jul 2012
Location: Down Under
Distribution: Mint 17 Qiana KDE
Posts: 87

Original Poster
Rep: Reputation: Disabled
SOLVED

Funny, only Shutter showed up after issuing your code. However, kontact did not start when i boot up this time (neither did shutter). Following is the result:

daisyb@psychobabe-Mint18-2 ~ $ grep Exec /home/daisyb/.config/autostart/*.desktop
Exec=shutter
daisyb@psychobabe-Mint18-2 ~ $ -name autostart -type d
No command '-name' found, did you mean:
Command 'uname' from package 'coreutils' (main)
-name: command not found

Very sorry if this was a wild goose chase. Many thanks for the responses in helping me out. I've marked it as SOLVED in title.

Have a very merry Christmas & all the best for 2018!
 
Old 12-24-2017, 12:01 PM   #8
Habitual
LQ 5k Club
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: High Sierra
Posts: 9,058
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by dwhb View Post
Funny, only Shutter showed up after issuing your code. However, kontact did not start when i boot up this time (neither did shutter). Following is the result:

daisyb@psychobabe-Mint18-2 ~ $ grep Exec /home/daisyb/.config/autostart/*.desktop
Exec=shutter
daisyb@psychobabe-Mint18-2 ~ $ -name autostart -type d
No command '-name' found, did you mean:
Command 'uname' from package 'coreutils' (main)
-name: command not found

Very sorry if this was a wild goose chase. Many thanks for the responses in helping me out. I've marked it as SOLVED in title.

Have a very merry Christmas & all the best for 2018!
Happy Holiday to you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to autostart dockapps and other stuff in BBox GUI login in slack? BW-userx Slackware 6 03-07-2017 02:50 PM
xfce4 repeatedly launches autostart applications on second login buginprogram Linux - Software 4 03-19-2014 02:38 PM
Unable to autostart graphical login - default init set to 5 in /etc/inittab jrella SUSE / openSUSE 4 06-25-2008 07:27 AM
autostart programs at login asgari22 Fedora 7 01-31-2005 04:12 PM
kaffeine stop autostart thegreatgatsby Linux - Software 3 11-30-2004 01:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration