LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 10-22-2008, 09:55 PM   #1
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Rep: Reputation: 51
How to stop auto-logout?


My machine logs me out after X hours. I don't mean logs out of ssh, I mean if I'm sitting at my machine, then leave for a couple hours, when I come back, I've been logged out & am back at the login screen. This doesn't bode well for the apps I run that take several hours to complete.

I don't have a TMOUT env var set, so it's happening somewhere else.

I'm using gnome/metacity.

Any ideas where I should look?

Last edited by BrianK; 10-22-2008 at 10:09 PM.
 
Old 10-22-2008, 10:58 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 6, KDE Neon
Posts: 4,313

Rep: Reputation: 211Reputation: 211Reputation: 211
I would start by taking a look at your .xsession-errors file in your home directory.
 
Old 10-22-2008, 11:04 PM   #3
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Linux Mint 17, Debian 8
Posts: 7,865

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
Also take a look at your screensaver options in gnome. They might be messed up.

------------------
Steve Stites
 
Old 10-23-2008, 01:29 PM   #4
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Original Poster
Rep: Reputation: 51
hmm... good ideas, but no lock so far:

Code:
cat .xsession-errors
/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "briank"
/etc/gdm/Xsession: Beginning session setup...
SESSION_MANAGER=local/akane:/tmp/.ICE-unix/31333,inet6/akane:44287,inet/akane:57701
** Message: Starting remote desktop server
Gnome-Message: gnome_execute_async_with_env_fds: returning -1
Gnome-Message: gnome_execute_async_with_env_fds: returning -1
seahorse nautilus module initialized
Initializing gnome-mount extension
Initializing nautilus-open-terminal extension
Introspect error: The name org.xchat.service was not provided by any .service files
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
Warning: more than one line!
Warning: more than one line!
Warning: more than one line!
Warning: more than one line!
Warning: more than one line!
Warning: more than one line!
Warning: more than one line!
Warning: more than one line!
I also looked in /etc/gdm/Xsession & all the files that are included in that. Nothing obvious stood out that looked like "timeout" or "logout" or "auto*"

I'm using the gnome screensaver so there aren't too many options there.

FWIW, this is a company-wide setting that our last admin put in place. He left in a hurry & didn't bother documenting anything like this, so I'm trying to find & remove this setting as its interfering with more than just my work.
 
Old 10-24-2008, 06:12 PM   #5
BrianK
Senior Member
 
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Original Poster
Rep: Reputation: 51
For the record, if anyone else comes across this, the auto-logout feature (in my case) was a custom deal made by our former admin that was tied into several site-wide applications & was rooted in a python deamon.

It's loads of fun uncovering all this custom, undocumented functionality.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
auto logout sysfriend Linux - Newbie 1 12-06-2005 03:20 PM
I want noatun to NOT stop when i logout DropSig Linux - General 4 06-14-2005 09:44 PM
auto logout ziox Linux - General 1 11-21-2004 06:31 PM
auto logout from KDE 3.2 jbasement Debian 9 02-28-2004 08:42 PM
Auto logout in Xsession nightoil Linux - Newbie 3 12-09-2003 05:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration