LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 11-26-2001, 09:43 AM   #1
Rex_chaos
Member
 
Registered: Aug 2001
Location: GD, GZ, China
Posts: 240

Rep: Reputation: 30
Question How to setup my mouse?


Hello all,
I have setup my mouse(Microsoft IntelliMouse, USB interface) while I install linux. However, it didn't work. I run setup under the shell window and choose the mouse setup term, it report error to setup mouse. How can I setup my mouse? Thanks.
 
Old 11-26-2001, 03:24 PM   #2
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
Which distribution are you using? mouseconfig is in alot of them and you can try that. If USB isn't loading at boot then you won't get a mouse at all. You should have a file in which you can uncomment lines to load modules such as USB HID support and so on. Depending on the distro is where the file is and what it's named. Some things to look into...Any other info helps.
 
Old 11-26-2001, 10:16 PM   #3
Rex_chaos
Member
 
Registered: Aug 2001
Location: GD, GZ, China
Posts: 240

Original Poster
Rep: Reputation: 30
My linux is RH7.1
 
Old 11-27-2001, 12:17 AM   #4
azazil
LQ Newbie
 
Registered: Nov 2001
Location: India
Distribution: RedHat 7.1
Posts: 18

Rep: Reputation: 0
Check your Xconfig (etc/X11/XF86Config) for follwoing lines..


Section "InputDevice"
Identifier "MyMouse"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
EndSection

(the last two "Option" lines enable the use of the wheel)

If you do not have the special file /dev/input/mice, you can create it by runnig:
mknod /dev/input/mice c 13 63

This is a working example from a config fiel for a slackware 8.0. I guess same should work for you too.. just make sure that you using the IMPS/2 protocol..

Hope this is of some help to you,
Have fun..

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Setup Rufus330Ci Linux - Hardware 7 08-21-2005 11:06 PM
setup up a usb mouse djgerbavore Linux - Newbie 7 01-31-2005 06:03 PM
Setup An Mouse HooX Linux - Newbie 2 01-10-2005 11:39 AM
Mouse setup problems for a 8 button mouse. Devboy Linux - General 3 12-25-2004 04:53 PM
Mouse speed setup on SUSE 8.2 maldiv Linux - Hardware 2 07-24-2003 10:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration