LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 08-24-2001, 01:42 AM   #1
cmardhekar
LQ Newbie
 
Registered: Aug 2001
Location: india
Posts: 17

Rep: Reputation: 0
how to set iptables in redhat linux 7.1


if i try to run iptables any command from root prompt for eg.

iptables -L
it give error
/lib/modules/2.4.2-2/kernel/net/ipv4/netfilter/ip_tables.o: create_module: Opera
tion not permitted
/lib/modules/2.4.2-2/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/
2.4.2-2/kernel/net/ipv4/netfilter/ip_tables.o failed
/lib/modules/2.4.2-2/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables fai
led
iptables v1.2.1a: can't initialize iptables table `filter': Permission denied (y
ou must be root)
Perhaps iptables or your kernel needs to be upgraded.


can any one guide me how to do the rules


chandrakant
 
Old 08-24-2001, 03:22 AM   #2
drjimstuckinwin
Member
 
Registered: Mar 2001
Location: Manchester UK
Distribution: Mainly Fedora
Posts: 496

Rep: Reputation: 30
Hi
Looks like you've still got IP chains. Thus no IP tables to use.
You're heading for a recompile, or just use chains. There's dozens of threads on the boards about howto set it up.
Jim
 
Old 08-24-2001, 10:22 PM   #3
mikeyt_3333
Member
 
Registered: Aug 2001
Distribution: Red Hat
Posts: 61

Rep: Reputation: 15
no need for a recompile. Simply type the following:

service ipchains stop

chkconfig --levels 2345 ipchains off

Reboot to allow chkconfig settings you set to take effect, then type:

service iptables start (if it's installed of course) and you shouldn't get that error.

What you've done is prevented the ipchains from loading at all at the run levels 2,3,4 and 5
 
Old 08-24-2001, 11:25 PM   #4
mikeyt_3333
Member
 
Registered: Aug 2001
Distribution: Red Hat
Posts: 61

Rep: Reputation: 15
k, my previous post is missing one thing:

rmmod ipchains

this removes the ipchains module from loading into the kernel, now iptables should work okay.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set workgroup in linux redhat 9 vanhelsing Linux - Networking 4 09-03-2004 05:08 PM
How to set JAVA_HOME in REDHAT 9.0 Linux? tejpatil Linux - Newbie 5 05-23-2004 01:17 PM
How to set JAVA_HOME in REDHAT 9.0 Linux? tejpatil Linux - General 1 05-23-2004 06:32 AM
insmod for iptables for Redhat Linux 9.0 yuva_mca Linux - Security 3 03-08-2004 07:24 PM
RedHat 8 Linux Lab Network Set Up Help Mike65 Programming 6 02-23-2003 11:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration