-   Linux - General (
-   -   How to overcome the RPM "mysql-5.0.27-1.fc6" conflict with mysql database starting (

kamakshiganesh 10-22-2007 07:07 AM

How to overcome the RPM "mysql-5.0.27-1.fc6" conflict with mysql database starting

I am having problem with mysql starting today in linux fedora core 6, i installed some RPMs from the net for skype installation, i think i am facing the problem after that installation.

I tried starting mysql from /usr/local, the location where i installed mysql

but after executing this command " bin/mysqld_safe --user=mysql &"

Its coming like mysql is starting from /var/lib/mysql, which i never mentioned

and message coming like "STOPPING server from pid file /var/run/mysqld/"

But there is no directory named mysqld or file in /var/run location.

I posted a thread in this discussion forum and got the reply as

“Chances are something has overwritten your /etc/my.cnf file. You may want to check and re-edit it. You can also check to see if there is a copy left behind with a .rpmsave extension.

You should also use 'rpm -qf /etc/my.cnf' to check if there is an RPM that owns the replaced file, as it may have added other items that are going to cause you problems.”

As per the reply, i executed the command “ rpm -qf /etc/my.cnf” .The rpm “mysql-5.0.27-1.fc6” is displayed.

Can u please guide me what i need to do further,shall i need to delete that rpm or how can i continue with the mysql without conflict.

And also i checked for a file named my.cnf in my /etc/ folder, the file is exist there, but before that i am not having that my.conf file, so i removed that file and tried starting mysql, then its coming like

[root@localhost mysql1]# bin/mysqld_safe --user=mysql &
[1] 3695
[root@localhost mysql1]# Starting mysqld daemon with databases from /usr/local/mysql1/data
STOPPING server from pid file /usr/local/mysql1/data/
071022 13:01:09 mysqld ended

Thank you
Best Regards

All times are GMT -5. The time now is 06:06 PM.