-   Linux - General (
-   -   how to mount ntfs on linux? (

piyusharora420 12-29-2010 12:21 AM

how to mount ntfs on linux?
hi everybody,
i have installed three flavours of linux on vmware
2.centos 5.5
3.fedora 14

and also install centos 5.5 on a seprate hard disk(not on vwware)

i want to mount my pen drive on linux which is ntfs.i have tried a lot on rhel5 only.please tell whether it is possible mount ntfs on any distributions i have mentioned above?

i have already installed fuse,fuse-devel,fuse libs,ntfs-3g,ntfs-3g libs on rhel5.but i still got error
"fatal : module fuse not found"
"ntfs unknow file system"

please tell me what things are left?

kirukan 12-29-2010 12:38 AM

1. Confirm the ntfs module on this path itself(the directory should be the kernel version)

cd /lib/modules/2.6.18-5-686/kernel/fs/
2. Confirm any device detect with NTFS

fdisk -l | grep NTFS

piyusharora420 12-29-2010 01:37 AM

cd /lib/modules/2.6.18-5-686/kernel/fs/
is giving the following error


bash: cd: /lib/modules/2.6.18-5-686/kernel/fs/: No such file or directory
so it means modules are not installed but i have done it.what is the root cause of this error?

kirukan 12-29-2010 01:48 AM

Please find right path as i mentioned

[root@Est ~]# uname -r
[root@Est ~]#
[root@Est ~]#
[root@Est ~]# cd /lib/modules/2.6.18-164.el5/kernel/fs/

Xeratul 12-29-2010 04:20 AM

for a ro:

mkdir /mnt/ntfs
mount /dev/XXX /mnt/ntfs

for a rw:

apt-get install ntfs-3g
then config the /etc/fstab

/dev/XXX /mnt/XXX ntfs-3g auto,user,defaults,force 0 0
##echo "/dev/hda1      /mnt/hda1      vfat    user,rw,auto,umask=0000,uid=1000,gid=1000  0    2" >> /etc/fstab

piyusharora420 12-30-2010 01:31 AM

IN /lib/modules/2.6.18-5-686/kernel/fs/
ntfs is not available.but i have installed ntfs-3g

piyusharora420 01-01-2011 01:10 AM

it works for me on centos 5.5 after installing all reqd packages but it worked only once.again it is not detecting ntfs filesystem

piyusharora420 01-04-2011 01:15 AM

please somebody help me.i want to use ntfs on rhel5 but it is not working at all even after installing the all reqd rpms

networking.dept 01-09-2011 03:59 AM

NTFS Partition Mounting on RHEL 5

You can go through following for Mounting NTFS Partition on RHEL 5 :-


piyusharora420 01-09-2011 04:14 AM

its not to know if kernel is pae or xen ?

networking.dept 01-09-2011 11:43 AM


It is working fine. Many of tried it and worked for them, This is my blog itself and i have posted it after successful test.

Requesting you to check steps carefully and the try to follow it, It should work. If not then tell me where exact you are facing difficulties.

To knowing what kernel you are usign Please Execute Following Command :-

# uname -r

scottro11 01-09-2011 11:45 AM


piyusharora420 01-10-2011 01:16 AM

in centos it is working.the problem is in rhel5.its not working at all.uname -r only tell about version nothing else.

jschiwal 01-10-2011 01:27 AM

"uname -r" should indicate which kernel version you are using. If it is a xen or pae kernel, you will see xen or pae in the name.

Check with "lsmod" if the "fuse" module is loaded. If not, modprobe it. Make sure you use "ntfs-3g" in your mount command or fstab file for the filetype.

You don't need CONFIG_NTFS_FS enabled in your kernel if you use ntfs-3g.

zcat /proc/config.gz | grep -i ntfs
# CONFIG_NTFS_FS is not set

You can check a filesystem with:
sudo file -s /dev/<device_node>

piyusharora420 01-10-2011 01:46 AM

its not finding fuse.showing module fuse not found.i have installed on centos as well as on rhel5 by same way.but its not working in rhel5.

All times are GMT -5. The time now is 10:00 PM.