-   Linux - General (
-   -   how to mount fat32 usb hard disk (

gvrglife 02-15-2003 09:25 PM

how to mount fat32 usb hard disk
When I try to mount my USB hard drive at /dev/sda with

mount -t vfat /dev/sda /mnt/usb

I get an error:

mount: wrong fs type, bad option, bad superblock on /dev/sda, or too many mounted files systems

And also when i open the browse hardware, it seems that it does not recognise the partition as fat32.

What does this mean? How can I get my drive mounted? Thanks!

Half_Elf 02-16-2003 12:38 AM

I don't think you have something at /dev/sda
Take a look at /dev/sda4
Except for a cdrom and some special device, you always have to give the partition number). Do "fdisk /dev/sda" then "p" to see the complete schema of that drive.

gvrglife 02-22-2003 09:06 PM

Can't mount /dev/sda4 neither
When i fdisk -l /dev/sda , i got nothing.
It seems that linux can't read the partition table.
What i'm sure is that linux did recognise the usb disk
coz i could see it in the hardware browser as sda with
no partitions at all.

I've recently reformatted the usb disk with partition magic
but to no avail. still same problem.

Could it be becoz i've no OS on the usb disk?

May b i should make the disk as an extanded partition?

Or may be should i reformat it in linux? (if so what
program should i use and how to?)
If i reformat it in linux would windows be able to see
the disk????


There are so many may bs I'm completely lost

d33pdream 02-22-2003 10:01 PM

do something like;

dmesg | grep sda

when you muont your usb disk, you cannot mount hte device, you must mount a partition on it (sdaX : where X = the parition number).

If you do not have a parition assigned use fdisk or cfdisk (er some sort of fdisk-like app)

does this help at all?

d33pdream 02-22-2003 10:03 PM

or perhaps you do not have the proper module installed to read into it's filesystem?


gvrglife 02-24-2003 02:24 AM

I tried the dmesg | grep sda
And i've got the following response:

sda: I/O error: dev 08:00,sector 0
SCSI device sda: 39070081 512-byte hdwr sectors(20004MB)
sda: test WP failed, assume Write Enabled

Well i don't understand anything!!!!
I know that the filesystem is fat32 so that mounting with vfat should work, but didn't........

MikeVx 02-25-2003 09:55 PM

Use dmesg | less to find out what your drive mounted at, if it is /dev/sda, try the following, a variant of which I use frequently.

mount /dev/sda1 /mnt/usb -t vfat

Note that mounting a device with no partition specified is not possible under any circumstances that I've heard of.

Also, /dev/sda4 would be valid if you were using an Iomega removable drive, such as a USB Zip drive.

nakkaya 02-25-2003 10:54 PM

i mount mine like that /dev/sda1 and file system i leave it as default worked for me

Pcghost 02-26-2003 02:22 PM

I mount mine in the same way as nakkaya. Be careful. I tried to hook my Maxtor 60gb external back up to a windoze machine after sucessfully mounting it in windows and lost a lot of data. Has anyone else had this happen? Try each of the sda's until you see the light flicker on the drive.

nakkaya 02-27-2003 02:18 AM

if you plug it out before mounting this will happen cause it doesnt write some data until you unmount it

gvrglife 02-27-2003 04:06 AM

Note that my USB drive is not a USB Zip drive.

Actually its a usual laptop harddisk which has been provided with a usb interface so that it can b pluggeg in via the usb port.

May b that's the reason y i can't mount it???

All times are GMT -5. The time now is 02:41 PM.