LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 07-09-2012, 10:57 PM   #1
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 53

Rep: Reputation: 17
Question How to mix S/PDIF input and PCM Out (to hear PCM and S/PDIF simultaneously)?


In alsamixer I can select either PCM Out or IEC958 In (that's my S/PDIF input) but not both. Is there a solution?

Note: I need stereo sound, so selecting IEC958 In for one channel, and PCM Out for the other is not an option.

I even tried OSS4, but it's the same: cannot hear S/PDIF input and PCM Out simultaneously. I feel like I'm missing something obvious and I would really appreciate any help.
 
Old 07-10-2012, 08:07 PM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
could you post an image of your alsamixer pls

Code:
alsamixer -v all
link it from any image sharing site you prefer.....here is mine as an example with pcm out up and good and spdif enabled....but I don't have the hardware connected up for spdif...giggles

http://imagebin.org/220268

2) next I assume you are trying to require output of spdif and pcm...but you have not mentioned your hardware sound specs so post

aplay -l
aplay -L
cat /proc/asound/devices

you may then look at creating an .asoundrc file that might mix them......YMMV

3) if your asoundrc fails.....then cheat and look at someone elses eg

http://forum.xbmc.org/showthread.php?tid=96138

4) and if still fails.....consider installing sound server eg pulseaudio or jack

good luck

---------- Post added 11-07-12 at 09:07 ----------

could you post an image of your alsamixer pls

Code:
alsamixer -v all
link it from any image sharing site you prefer.....here is mine as an example with pcm out up and good and spdif enabled....but I don't have the hardware connected up for spdif...giggles

http://imagebin.org/220268

2) next I assume you are trying to require output of spdif and pcm...but you have not mentioned your hardware sound specs so post

aplay -l
aplay -L
cat /proc/asound/devices

you may then look at creating an .asoundrc file that might mix them......YMMV

3) if your asoundrc fails.....then cheat and look at someone elses eg

http://forum.xbmc.org/showthread.php?tid=96138

4) and if still fails.....consider installing sound server eg pulseaudio or jack

good luck
 
1 members found this post helpful.
Old 07-11-2012, 01:35 AM   #3
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 53

Original Poster
Rep: Reputation: 17
Post

> could you post an image of your alsamixer pls
Here it is: http://science.su/stuff/sreenshot/alsamixer_-V_all.jpg

> I assume you are trying to require output of spdif and pcm
Yes, that's right, I want simultaneous output of S/PDIF input and pcm to my analog speakers.

> you have not mentioned your hardware sound specs so post
> aplay -l
> aplay -L
> cat /proc/asound/devices
Sorry about that. Here they are:

Code:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Audiophile192 [M Audio Audiophile192], device 0: ICE1724 [ICE1724]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audiophile192 [M Audio Audiophile192], device 1: ICE1724 IEC958 [ICE1724 IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Code:
aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
sysdefault:CARD=Audiophile192
    M Audio Audiophile192, ICE1724
    Default Audio Device
front:CARD=Audiophile192,DEV=0
    M Audio Audiophile192, ICE1724
    Front speakers
surround40:CARD=Audiophile192,DEV=0
    M Audio Audiophile192, ICE1724
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Audiophile192,DEV=0
    M Audio Audiophile192, ICE1724
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Audiophile192,DEV=0
    M Audio Audiophile192, ICE1724
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Audiophile192,DEV=0
    M Audio Audiophile192, ICE1724
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Audiophile192,DEV=0
    M Audio Audiophile192, ICE1724
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Audiophile192,DEV=0
    M Audio Audiophile192, ICE1724
    IEC958 (S/PDIF) Digital Audio Output
Code:
cat /proc/asound/devices
  2: [ 0- 0]: raw midi
  3: [ 0- 1]: digital audio playback
  4: [ 0- 1]: digital audio capture
  5: [ 0- 0]: digital audio playback
  6: [ 0- 0]: digital audio capture
  7: [ 0]   : control
 33:        : timer
> consider installing sound server eg pulseaudio
Tried it, but could not even get it to output S/PDIF input. No matter what I choose in pavucontrol, I only can hear PCM or nothing. It looks like pulseaudio is not something I want (does not solve my problem and in fact make it worse, breaks some applications, adds some latency), so I purged it.

> cheat and look at someone elses eg
> http://forum.xbmc.org/showthread.php?tid=96138
I "cheated" and tried to write my own based on the example you gave me. But it does not do anything except "muting" PCM Out (in other words I cannot hear PCM Out anymore even if I choose it in alsamixer, but I can hear S/PDIF In if I choose it instead). Even after reading http://www.alsa-project.org/main/index.php/Asoundrc I still do not understand what am I doing wrong. Here is my current /etc/asound.conf:
Code:
pcm.!default {
  type plug
  slave.pcm "dmixer"
}

pcm.clone_output {
  type plug
  slave.pcm "4channel_expander"
}
        
pcm.multi_pcm_device {
  type multi;
  slaves.a.pcm "hw:0,0"; # analog
  slaves.a.channels 2;
  slaves.b.pcm "hw:0,1"; # spdif
  slaves.b.channels 2;
  bindings.0.slave a;
  bindings.0.channel 0;
  bindings.1.slave a;
  bindings.1.channel 1;
  bindings.2.slave b;
  bindings.2.channel 0;
  bindings.3.slave b;
  bindings.3.channel 1;
}

ctl.multi_pcm_device {
  type hw;
  card 0;
}

pcm.4channel_expander {
  type route;
  slave.pcm "multi_pcm_device";
  slave.channels 4;
  ttable.0.0 1;
  ttable.1.1 1;
  ttable.0.2 1;
  ttable.1.3 1;
}

ctl.4channel_expander {
  type hw;
  card 0;
}
Since "0,0" is my analog microphone, "0,1" is S/PDIF so I think I have used correct hw #. I tried to replace "hw:0,1" with "plughw:0,1" but it did not gave any result either. And I do not understand why this asound.conf "mutes" PCM Out.

I would appreciate if somebody can suggest where I did a mistake(s) in my asound.conf.

Last edited by *Dark Dragon*; 07-11-2012 at 02:19 AM.
 
Old 07-12-2012, 12:32 AM   #4
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
thanks for the info

firstly I agree that spdif is hw:0.1

but I suspect your claim of purged pulseaudio is not quite true so some more tests

but lets look at another easy one that you have done but I can't see

your alsamixer image

1) what happens on each control that "allows" it....to press the up or down arrows.....do you get options for example at control 2, currently showing as pcm out....can it select spdif out.......and DITTO the other controls like HW and HW1 ....etc

1) see that pulseaudio is showing in aplay -L...our aim to either correctly configure pulse to work but based on your last reply, I assume you prefer the remove all pulse option

b) now if you still have pulse....here is a mixer idea
https://wiki.archlinux.org/index.php..._Analog_Output

one....you would set spdif as your default device
two ...you would add "normal" digital output hw:0,0 as the module as per this section,

Add the following to /etc/pulse/default.p to setup the analog as a secondary source:
### Load analog device
load-module module-alsa-sink device=hw:0,0
load-module module-combine-sink sink_name=combined
set-default-sink combined

2) otherwise you must truly purge pulse

I have just downloaded on debian to have look...as I don't have PA installed normally and this is a culled guide you can

Code:
su (or sudo su)
find / -name pulse*
/etc/dbus-1/system.d/pulseaudio-system.conf
/etc/xdg/autostart/pulseaudio-kde.desktop
/etc/xdg/autostart/pulseaudio.desktop
/etc/pulse
/etc/default/pulseaudio
/etc/init.d/pulseaudio
/usr/share/alsa/alsa.conf.d/pulse.conf
/usr/share/alsa/pulse-alsa.conf
/usr/share/pulseaudio
let me know if that interests you
 
Old 07-13-2012, 02:02 AM   #5
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 53

Original Poster
Rep: Reputation: 17
Post

> do you get options for example at control 2, currently showing as pcm out....can it select spdif out.......and DITTO the other controls like HW and HW1
Yes, I can. But we are talking about S/PDIF In here, not S/PDIF Out. So relevant controls are 6 and 7. I can select PCM Out, H/W In 0, H/W In 1, IEC958 In L, IEC958 In R on both. H/W In 0 is my microphone, H/W In 1 is unused analog input, IEC958 In L is left channel of stereo S/PDIF input, EC958 In R is the right channel.

> otherwise you must truly purge pulse
I did run sudo apt-get purge pulseaudio. For all intents and purposes pulseaudio (as a sound server) is purged (alsamixer have all controls, no pulseaudio process in the system). I have libpulse0 installed but I cannot remove it without ruining my system (321 packages depend on it, even the ones which have nothing to do with sound like ark or basket). This library is probably the reason why aplay -L shows pulseaudio as possible output.

> our aim to either correctly configure pulse to work but based on your last reply, I assume you prefer the remove all pulse option
At this point I'm willing to try anything that might work. I don't like PulseAudio, but if it is possible to make it work, I'm willing to give it a try.

> here is a mixer idea
> [url]https://wiki.archlinux.org/index.php/PulseAudio/Examples#Simultaneous_HDMI_and_Analog_Output[/url

OK, I installed pulseaudio again.

> one....you would set spdif as your default device
> two ...you would add "normal" digital output hw:0,0 as the module as per this section

My digital output is hw:0,1, but again, we are talking about digital input, and that's plughw:0,1. The problem that I cannot even choose it as default source with pulseaudio. When pulseaudio is running, alsamixer have only one control - Master. pavucontrol does not allow me to change what device I hear, its always PCM Out or nothing. So I cannot (at least I have no idea how) choose plughw:0,1 as my default device for outputting to hw:0,0 (my analog speakers). At this moment, it looks to me this is possible only with alsamixer without pulseaudio running.

> load-module module-alsa-sink device=hw:0,0
> load-module module-combine-sink sink_name=combined
> set-default-sink combined

I think you are describing PCM output to 2 hardware outputs instead of combining PCM Out (sounds my computer makes) and plughw:0,1 (S/PDIF In, sounds from external computer/device) for one output hw:0,0 (the analog speakers) so I can hear S/PDIF and PCM Out simultaneously (as the subject says).

I tried to play with the /etc/pulse/default.pa, but could not force pulseaudio to even reroute plughw:0,1 to hw:0,0 (I have tried "load-module module-alsa-source device=plughw:0,1", but it looks like either it does not work or does not do what I think it does - could not find any documentation about this parameter).

With alsamixer I can reroute plughw:0,1 to hw:0,0 without any problems with controls 6 and 7 on my sreenshot, but what I want and cannot do with alsamixer is to combine plughw:0,1 and PCM Out and hear the result from hw:0,0. I think this is may be possible with proper asound.conf but my attempt to write one have failed - there is no any real documentation about asound.conf and debugging tools for it, at least I could not find them.

So, short summary:

With alsamixer without pulseaudio I can get:
plughw:0,1 -> hw:0,0
or
PCM Out -> hw:0,0

With pulseaudio I'm able to get only this:
PCM Out -> hw:0,0

But what I want is this:
PCM Out + plughw:0,1 -> hw:0,0

Last edited by *Dark Dragon*; 07-13-2012 at 02:07 AM.
 
Old 07-14-2012, 03:59 PM   #6
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 53

Original Poster
Rep: Reputation: 17
I tried JACK, from its description it looks like it may help to achieve my goal, but unfortunately when I run qjackctl I see only analog inputs/outputs in the Audio tab:
capture_1, capture_2 (that's plughw:0,0)
playback_1, playback_2 (that's hw:0,0)
...and do not see controls for plughw:0,1 (S/PDIF stereo input) and hw:0,1 (S/PDIF stereo output). PCM Out is missing too. I have no idea how to add missing inputs/outputs to JACK, reading the documentation and googling did not help. Tab "MIDI" in qjackctl is empty, and tab "ALSA" contains only MIDI devices.

If anybody can help or suggest something, I will really appreciate it!
 
Old 07-14-2012, 05:58 PM   #7
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,570

Rep: Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349Reputation: 2349
I know it's a different card but envy24control worked well with my Audiophile 24/96, have you tried it?
 
Old 07-14-2012, 06:29 PM   #8
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 53

Original Poster
Rep: Reputation: 17
No, I did not try because it is for ICE1712 cards only. My card is based on ICE1724. And I have no idea what envy24control allows to achieve exactly (its man page doesn't say much). But just to be sure I tried now and it refused to run:
Code:
% envy24control
No ICE1712 cards found
ICE1712 and ICE1724 are different in many ways, so this is expected.
 
Old 07-14-2012, 07:22 PM   #9
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
Quote:
we are talking about digital input
hullo are we talking different things?

maybe I misunderstood.

do you want to take the input to spdif (input) and send to spdif output same time to pcm out?

I am confused.

Quote:
iec958:CARD=Audiophile192,DEV=0
M Audio Audiophile192, ICE1724
IEC958 (S/PDIF) Digital Audio Output
on your alsamixer image.....which one is spdif input?
 
Old 07-14-2012, 07:26 PM   #10
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
and pulseaudio....we are not re-routing but combining sounds out devices
 
Old 07-14-2012, 09:04 PM   #11
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 53

Original Poster
Rep: Reputation: 17
Post

Quote:
Originally Posted by aus9 View Post
I am confused.
Not sure why you are confused. I never mentioned S/PDIF output in my messages until you started talking about it your previous message. Also, you wrote there "digital output hw:0,0", but hw:0,0 is analog output (cat /proc/asound/devices lists both S/PDIF and analog inputs/outputs as "digital", perhaps this is what confused you).

Quote:
Originally Posted by aus9 View Post
do you want to take the input to spdif (input) and send to spdif output same time to pcm out?
Almost. But not to S/PDIF output but to analog output (hw:0,0). As I wrote in one of my previous messages:

"I want simultaneous output of S/PDIF input and pcm to my analog speakers"
"PCM Out + plughw:0,1 -> hw:0,0"

PCM Out represents stereo sounds from all programs in my computer.
plughw:0,1 is my S/PDIF stereo input (sound from external device).
hw:0,0 is my analog stereo output (my speakers).

With alsamixer, for example, I can take the input from S/PDIF In and send it to analog output but then I will not hear PCM Out. Or, I can send PCM Out to analog output, but then I cannot hear S/PDIF In. And I really need to hear them (PCM Out and S/PDIF In) simultaneously in real-time with minimal latency, so ability to switch between them gives me nothing.

This is why I spend so much time searching for a way how to solve this problem. Giving up is not an option for me, in worst case scenario I have to buy expensive hardware mixer. But this problem can be solved at software level, as far as I understand properly written asound.conf, or some special configuration of pulseaudio, or jack (if I find a way to make it "see" my digital input) can do what I want. Unfortunately, I have failed to do this by myself, and this is why I'm asking for help.

Quote:
Originally Posted by aus9 View Post
on your alsamixer image.....which one is spdif input?
As I have already wrote I can choose S/PDIF Input on controls 6 and 7 (they show what I hear from hw:0,0 - my analog speakers). Here is link to the output from amixer - it contains all my controls and all possible choices in alsamixer. S/PDIF input called "IEC958 In" there.

Quote:
Originally Posted by aus9 View Post
and pulseaudio....we are not re-routing but combining sounds out devices
I understand, but as I have said I couldn't get it to even reroute sound. If I can't reroute, it cannot combine. At least this is how I understood what you have said (you told me to choose S/PDIF as the default - basically reroute sound from plughw:0,1 to hw:0,0; it is easy with ALSA but could not figure out the way to do that with PulseAudio). Perhaps I'm missing something obvious but example you gave for PulseAudio only mentions hw:0,0 (analog output), it does not mention plughw:0,1 (S/PDIF In). As I have said, I want to combine sound from plughw:0,1 with PCM Out and then output combination of sounds from plughw:0,1 and PCM Out to hw:0,0.

Last edited by *Dark Dragon*; 07-14-2012 at 09:12 PM.
 
Old 07-20-2012, 07:53 AM   #12
*Dark Dragon*
Member
 
Registered: Apr 2005
Distribution: Debian Testing + KDE
Posts: 53

Original Poster
Rep: Reputation: 17
Lightbulb The solution

It seems that JACK is my only option. But the fact that PCM Out does not exist in JACK is a problem. Despite the fact that my sound card costs about $200 it doesn't support hardware mixing. Fortunately, I was able to solve this by using ALSA JACK plugin.

About my other problem with JACK... After careful reading of the documentation and Googling it turns out JACK works exactly as it should. I'm supposed to add non-default devices manually - either by creating one big multichannel ALSA device, or by using alsa_in/alsa_out - these two didn't work for me too well no matter what period size I have used, so I created multichannel ALSA device. What confused me in the first place is the fact that nearly everywhere people talk about this only in context of "unifying" multiple sound cards - but in reality this is necessary to use multiple ALSA devices in one card too.

By the way, I do not think anymore that it is possible to solve this without JACK. ALSA does not allow to mix input(s) with output(s): in alsamixer it is possible to reroute input to output, but impossible to mix them; in asound.conf it is possible to attempt to do so, but the result will be non-working ALSA device. PulseAudio have similar limitation. So, JACK is the only way to solve this problem.

Now, I will describe the solution. I tried many things, but all other configurations/method either gave me bad sound or worked similarly in practice, but were more complex. So I will give here the simplest solution that worked for me (and mention some alternatives which are likely to work at least for some people). I use Debian Testing, so some things I mention are Debian-specific. It should not be too hard to do the same in other distributions.


Install JACK
apt-get install qjackctl jackd2


Configure ALSA
Run this command:
sudo apt-get install libasound2-plugins
Here is my /etc/asound.conf (you can put its contents in ~/.asoundrc - but /etc/asound.conf is better place because it is system-wide). As you can see, it's relatively simple. Device "all" is intended for JACK, and !default - for all non-JACK applications. It is important that the !default is of type plug and not jack, otherwise you will get all sorts of strange problems. You can easily adapt my asound.conf to your needs - it is hopefully obvious how to add or remove audio devices and channels. If not, read the documentation.

IMPORTANT NOTE: If your sound card is capable of hardware mixing, you do not need !default section with ALSA JACK plug-in to hear sound from non-JACK applications. If you are unsure what your card is capable of, run:
cat /proc/asound/card0/pcm*/info | grep count
If at least some devices have more than 1 subdevice, your card is capable of hardware mixing. If hardware mixing is available on your default channels, you can remove !default section from my example of asound.conf.


Only problem in my asound.conf is that analog input (typically microphone) cannot be used as mono if you specified stereo analog input like me. Another strange thing is that I get a lot of XRUNs in JACK but they do not affect sound quality in my case, so I ignore them.

Alternative ALSA configuration (NOT recommended!)
It is possible to write asound.conf without ALSA JACK plug-in, but in my case this resulted in bad sounds with frequent click-like artifacts on inputs despite very large buffer_size (sometimes few artifacts per minute, sometimes one artifact per few minutes) even after upgrade to PF kernel (later I'll explain what is it). No surprise here, because JACK must use your audio devices as directly as possible and this is not the case here. If you want to try this anyway for whatever reason, please see my /etc/asound.conf without ALSA JACK plug-in. It is more complex than the first one, but I tried to make it as readable as possible. Before trying it, make sure that you are using the same period_size and periods in JACK and asound.conf. I leave this alternative configuration as an example to learn from (you can see how to use various types in asound.conf, how to upmix mono to stereo, etc.).


Configure JACK
Here is screenshot of my JACK settings in qjackctl. Most important settings are "Realtime", "Input device" and "Output device". Everything else is just an example of working setup.


Upgrade to better kernel
It is good idea to try to migrate to RT kernel (eventually vanilla kernel will include similar real-time support, but for foreseeable future you have to use patched kernel if you want acceptable audio latency with no artifacts, especially from audio input(s) ). To try RT kernel in Debian Testing or higher you need just run this command (I assume you need NVidia driver; if not, install whatever driver you need instead):

sudo apt-get install linux-image-3.4-trunk-rt-amd64 linux-headers-3.4-trunk-rt-amd64 nvidia-kernel-dkms

If RT kernel works for you, feel free to skip the rest of this message. With RT kernel you can hear perfect low-latency sound. But unfortunately many NVidia cards do not work with RT kernels, and mine was one of them (GeForce GTX 295), so I couldn't use RT.

Note: with vanilla kernel I encountered click-like artifacts few times per minute in both analog and digital inputs - this was unacceptable, so vanilla kernel did not work for my purpose. If it works for you and you are OK with relatively high audio latency (buffer) you have to tolerate for acceptable sound, you obviously do not need to change your kernel.

NVidia driver in Debian already contains modifications to work with 3.4 RT kernel, you do not need to modify it, but unfortunately it may give you black screen instead of your graphical interface. In this case, you have to uninstall RT kernel and try something else, for example PF-kernel. Author does not provide deb files, but links to somebody's site who does - this site written in non-English language, but whatever language it is, you do not need to understand it, just download deb files with pf kernel and its headers and install them with:

sudo dpkg -i linux-*-pf*.deb

PF kernel contains BFS scheduler, and in my Xeon-based quad core workstation with 8 hardware threads (so the OS sees it as 8 CPUs) it reduced worse-case latencies of real-time processes (like JACK) from hundreds of milliseconds to few milliseconds (in my case less than 2ms). This is of course looks as very bad result if you compare with RT kernel (with worst-case latencies of real-time processes within 10-30 microseconds range) but MUCH better than vanilla kernel. Personally I use 128 buffer_size with 2 periods - that's ~5ms latency; in my case this is enough to prevent any artifacts in the sound after few hours of testing. With RT kernel even better results should be possible.

Note: Yes, I know BFS is not the best scheduler, but it works much better then vanilla scheduler if you want low latency and RT kernel does not work for you. In case you want as small latencies as possible without RT kernel, there are improved BFS with O(1) complexity instead of O(n), and probably even better scheduler - RIFS. You can find them here if you up to compiling your own kernel. If you are, install kernel-package and read this howto.

Hope my experience will be useful to somebody.

Last edited by *Dark Dragon*; 07-20-2012 at 02:04 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
S/PDIF no audio (with alsa) laurensvp Linux - General 0 06-28-2010 04:44 PM
(Sound) what is PCM? what's the difference between PCM volume and master volume? snr8fl3 Linux - General 2 01-27-2009 06:12 AM
Alsa problems - no line/pcm input xj25vm Linux - Hardware 3 11-19-2008 10:23 PM
s/pdif does it work? leosgb Linux - Hardware 0 06-12-2006 01:05 AM
S/PDIF and mplayer/xine rch Linux - General 0 10-27-2003 12:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration