LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 08-25-2020, 09:22 PM   #1
Finsfree
Member
 
Registered: Aug 2018
Location: 3rd rock from the sun
Distribution: Ubuntu, Mint & Kali
Posts: 72

Rep: Reputation: Disabled
How to get Clonezilla to work using UEFI


I would like to share with the class an issue I had /w Clonezilla and UEFI. For two days I could not get this to work until now.

I have never had an issue with Clonezilla until now. I was trying to create an image from a newer Dell Optiplex 5070 desktop that had a NVMe HDD. Don't try installing Win10 in Legacy BIOS mode...it will not boot without the USB drive still connected to the machine...weird I know... If you remove the USB drive and then do a reboot the computer says it can't find a bootable disk.

To get Clonezilla to work with a newer Dell desktop like the Optiplex 5070 do this in the BIOS before installing Windows 10. Then create the image w/ Clonezilla:

1. "Disable" secure boot
2. Sata setting to "AHCI"
3. UEFI Boot Path Security set to "Never"

Hope this helps anyone dealing with this same issue.

https://jasoncoltrin.com/2018/02/09/...ernal-usb-hdd/

Last edited by Finsfree; 08-25-2020 at 09:49 PM.
 
Old 08-25-2020, 10:48 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,238

Rep: Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451
" if you need uEFI secure boot, please use AMD64 version of Clonezilla live. "

https://clonezilla.org/downloads/dow...?branch=stable

Should have been able to create a live media that would boot uefi but thanks for your report.
 
1 members found this post helpful.
Old 08-26-2020, 09:19 AM   #3
Finsfree
Member
 
Registered: Aug 2018
Location: 3rd rock from the sun
Distribution: Ubuntu, Mint & Kali
Posts: 72

Original Poster
Rep: Reputation: Disabled
Yes, I was using AMD64.

I should have titled the post, "How to get Clonezilla to work with NVMe drives". On the newer computers that use these drives, you have to make these changes in the BIOS.
 
Old 09-04-2020, 08:09 AM   #4
ppm2000
LQ Newbie
 
Registered: Dec 2010
Posts: 8

Rep: Reputation: 0
How to get Clonezilla to work using UEFI===
i have lenovo t440 thinkpad -using GPT and secure boot win 10 prof.

made the bootable usb with clonezilla-- option uefi NTFS bootloader and on finish the note was displayed that i must disable the secure boot before the usb can work.

so my doubt is that after disabling the secure boot -- then i make a image of the os partition and then when after crash i need to reinstall the os then use restore option and then when os loads ok go to bios and then change secure boot position ON ?
 
Old 09-04-2020, 04:35 PM   #5
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,238

Rep: Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451
"Hints

All versions of Clonezilla live support machine with legacy BIOS. If your machine comes with uEFI secure boot enabled, you have to use AMD64 (X86-64) version (either Debian-based or Ubuntu-based) of Clonezilla live.

Checksum files are GPG signed by DRBL project, which has the fingerprint: 54C0 821A 4871 5DAF D61B FCAF 6678 57D0 4559 9AFD. To verify, you can follow this doc.

Once you have the Clonezilla live iso or zip file, please follow this Live CD/USB doc to put it on the boot media, and follow this Live Docs to use it.
"
https://clonezilla.org/downloads.php

Did you follow the hints?
 
Old 09-06-2020, 01:24 AM   #6
ppm2000
LQ Newbie
 
Registered: Dec 2010
Posts: 8

Rep: Reputation: 0
clonezilla on win 10 with secure boot

i did as per the advice given above to create the clonezilla usb. used amd64 version . used rufus to create the usb. checked following options in rufus-- clonezilla live focal 20200703 iso .
partition scheme gpt
target uefi(non csm)
file system fat32
lenovo t440 thikpad (secure boot eneabled) set usb boot as first choice

connected usb and booted laptop note displayed was -- efi boot cannot be found and 2 more lines but i could not read it vanished fast.
now what do i do?
 
Old 09-07-2020, 05:06 PM   #7
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,238

Rep: Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451
So many variables that could be wrong.

I think you mean set usb as a hard drive order choice not boot to usb in bios.??


Try the instructions one by one.

"MS Windows Method A: Tuxboot"
 
Old 09-11-2020, 02:22 AM   #8
ppm2000
LQ Newbie
 
Registered: Dec 2010
Posts: 8

Rep: Reputation: 0
clonezilla on win 10 with secure boot

in bios page i can see my hp usb identified as usb hdd. selected the same to top position saved it before exit. and still on trying load clonezilla --remark is cannot find efi partition to boot.
md5 check of the down load of clonezilla is ok.

what else needs to done?
 
Old 09-11-2020, 04:50 PM   #9
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,238

Rep: Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451Reputation: 3451
Actually post new thread on this cause you are hijacking the original.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get dual boot, win 7 uefi and elementary freya os uefi working shywolf Linux - Newbie 4 12-10-2015 07:14 PM
Can't install LM 32bit with UEFI disabled on UEFI Asus X200MA laptop dblaisde Linux Mint 3 10-15-2015 06:37 AM
LXer: Clonezilla-release Stable Clonezilla live (2.0.1-15) Released LXer Syndicated Linux News 0 12-18-2012 10:21 PM
Help Creating UEFI A MENU For My Bootable (BIOS/UEFI) CDROM ssenuta Linux - Hardware 0 08-27-2012 10:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration