-   Linux - General (
-   -   how to disable sleep/hibernate mode in runlevel 3 mode (

libin88 11-21-2008 11:10 AM

how to disable sleep/hibernate mode in runlevel 3 mode
My machine installed FC8, when it runs in runlevel 3, its conosle always went to sleep or hibernate mode in every 10 minutes, I have to press keyboard from time to time to keep it active. Do you know how to disable it?


blackhole54 11-23-2008 04:54 AM

Does the computer actually go into hibernate (which takes a while to shutdown and start backup and results in the computer actually being turned off) or does the screen just go blank? If it is the latter, try the following command after logging in at the console:


setterm -powersave off -blank 0
If this takes care of you problem, you can add it to your ~/.bash_profile or /etc/profile file so that it runs automaticly each time you log in (so you don't have to type it). The tilde (~) in ~/.bash_profile just means your home directory. (This will apply the command only to users who have added it to their own .bash_profile directory. The /etc/profile file will automatically apply it to all users.) You can use your favorite text editor, but be aware that the leading dot in the name of .bash_profile makes it a "hidden file" so it doesn't show up with ls command unless you use the -A or -a option (or you specify the file by name). If you wish to modify /etc/profile you will have to do so as root.

If your screen is going blank before you log in and this is a problem for you, then you will need to alter a different configuration file and I am not familiar with Fedora so I cannot help you with that.

Be aware that the command above is turning off a power saving feature. You might want to consider whether you really want to do that. Perhaps you would wish simply to extend the period before it blanks the screen. You can check out the man page for the setterm command for an explanation of all the options available to you. To read the man page, just type:


man setterm

All times are GMT -5. The time now is 01:18 PM.