LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-21-2015, 10:08 PM   #1
keithostertag
Member
 
Registered: Jul 2011
Location: Harrisburg, PA
Posts: 120

Rep: Reputation: Disabled
How to completely remove service from systemd using systemctl? OpenSUSE


I want to completely get rid of plymouth-start.

I disabled plymouth-start and stopped it using systemctl, then used zypper to remove the package from the system.

It still shows up when checking with systemctl:

Code:
sam14:/home/keith # systemctl status plymouth-start
plymouth-start.service
   Loaded: not-found (Reason: No such file or directory)
   Active: failed (Result: signal) since Wed 2015-01-21 22:37:17 EST; 21min ago
 Main PID: 225 (code=killed, signal=SEGV)
It is probably not doing any harm, but I'd like to remove it so it doesn't show up in systemctl at all. Reading the man page for systemctl has not revealed to me how to do it.

It still shows up when I list units that failed to load:
Code:
sam14:/home/keith # systemctl --failed
UNIT                   LOAD      ACTIVE SUB    DESCRIPTION
plymouth-start.service not-found failed failed plymouth-start.service
Ideas? I'm using OpenSUSE 13.2.

Thanks,
Keith Ostertag
 
Old 01-22-2015, 12:34 AM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,097

Rep: Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325
Don't know why you'd care, but looking at the unit definition in Fedora, looks like they allow a kernel option "plymouth.enable=0" to disable it.
Don't have a OpenSUSE system to check, but should be easy enough to see if it also applies there.
 
Old 01-22-2015, 07:27 AM   #3
keithostertag
Member
 
Registered: Jul 2011
Location: Harrisburg, PA
Posts: 120

Original Poster
Rep: Reputation: Disabled
Thank you for responding.

I care simply because I should be able to completely purge it (or any program) from my system, agreed?
 
Old 01-29-2015, 08:06 PM   #4
keithostertag
Member
 
Registered: Jul 2011
Location: Harrisburg, PA
Posts: 120

Original Poster
Rep: Reputation: Disabled
I subsequently got rid of that pesky error message by running mkinitrd for some other unrelated problem.

More subsequent reading of the man page suggests that

Code:
systemctl disable plymouth-start.service
should work, but I haven't had the chance to test that.

Keith Ostertag
 
Old 01-29-2015, 09:27 PM   #5
Doug G
Member
 
Registered: Jul 2013
Posts: 749

Rep: Reputation: Disabled
systemctl mask <unit> won't uninstall but will completely hide the service unless you later unmask it.
 
Old 01-30-2015, 05:26 AM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
You have removed Plymouth already, all that is left is the .service file. You can simply remove that by hand, if you are bothered by it.
 
1 members found this post helpful.
Old 01-30-2015, 05:33 AM   #7
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Debian stable (and OpenBSD-current)
Posts: 1,187

Rep: Reputation: 285Reputation: 285Reputation: 285
For future reference, look at the output of:
Code:
ls -l /etc/systemd/system/multi-user.target.wants
and delete any dangling symlinks for that .service
 
1 members found this post helpful.
Old 01-30-2015, 10:26 AM   #8
keithostertag
Member
 
Registered: Jul 2011
Location: Harrisburg, PA
Posts: 120

Original Poster
Rep: Reputation: Disabled
Ok, thanks guys! Good info! I appreciate you taking the time to help me out.

Keith Ostertag
 
Old 07-06-2015, 01:42 PM   #9
lakata
LQ Newbie
 
Registered: Jul 2015
Posts: 1

Rep: Reputation: Disabled
I found the answer was to run

Code:
    systemctl reset-failed
to get rid of the warning messages. Of course, you need to disable the service and remove all of the files as well.

See

http://serverfault.com/questions/606...-systemd-units
 
Old 08-27-2015, 04:54 PM   #10
nnsense
LQ Newbie
 
Registered: Jun 2015
Posts: 1

Rep: Reputation: Disabled
Had exactly the same issue this evening, exactly with the same service, just wanted to say thank you, I didn't know about that `systemctl reset-failed`
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] What is the purpose of systemctl start named.service? Echopurrs Linux - Newbie 1 07-07-2014 12:43 AM
[SOLVED] systemctl enable mysqld.service, command not working. cyberdome Fedora 5 03-10-2014 12:36 PM
systemctl start php-fpm.service question satimis Linux - Server 2 11-26-2012 07:25 AM
Boot Delay 30min: systemd-analyze blame systemd-tmpfiles-setup.service BGHolmes Fedora 0 07-27-2011 09:02 AM
How to remove a service completely ? gardenair Linux - Newbie 5 05-18-2010 03:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration