LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   How install the Wine program. (https://www.linuxquestions.org/questions/linux-general-1/how-install-the-wine-program-297731/)

Gins 03-04-2005 04:06 PM

How install the Wine program.
 
I downloaded the following file:

wine-20050211-mdk.i586.rpm

The idea is that I want to read my windows file using this program. My computer has both Windows and Linux. When it starts, I can select either Linux or Windows.

From the Linux side I want to read and copy some files on my Windows partition.

I am running Mandrake Linux 10.0

Could you help me to install the downloaded 'wine program' ?

What is the first step?

XavierP 03-04-2005 04:47 PM

You install any .rpm file with
Code:

rpm -ivh <programname>.rpm
You will only really be able to access your Windows files if they are on a FAT32 partition, there are programs to allow read/write to NTFS, but they are very experimental and usually come with big disclaimers.

Gins 03-04-2005 05:22 PM

Thanks Xavier

I have them on Windows 2000; my windows side is Windows 2000. There are some important files in that partition. I must copy them to Linux. I have some grave problems in Windows 2000. It is almost a dead partition. I am going to partition it. Before doing it, I must copy some important files.

I will contact you again.

Gins 03-05-2005 09:34 AM

I have some problems of installing the program. I log in to the system as a root user and loˇked for the downloaded file.
It was a 13MB file.
The following command searched the file.
find -name '*' -size +10000k

I used my Opera browser to download the program.

[hey@h27n2fls301o1037 hey]$ su root
Password:
[root@h27n2fls301o1037 hey]# find -name '*' -size +10000k

./Adobe Acrobat Reader for Linux/LINUXRDR.TAR
./.opera/download/wine-20050211-mdk.i586.rpm
./.opera/cache4/opr000M2.rpm
[root@h27n2fls301o1037 hey]#

---------------------------------------------------------------
[root@h27n2fls301o1037 hey]# cd Opera
[root@h27n2fls301o1037 Opera]#
--------------------------------------------------------------------------


[root@h27n2fls301o1037 Opera]# rpm -ivh wine-20050211-mdk.i586.rpm
error: open of wine-20050211-mdk.i586.rpm failed: No such file or directory.


What is the problem? It says no file or directory. That is rubbish. As you see in the given details, there is a file.

Please help me.

XavierP 03-05-2005 11:25 AM

You need to cd to the download directory that is within the Opera directory.

Gins 03-05-2005 12:55 PM

Thanks Xavier.

I knew this. So I in vain tried to go into the folder called 'download'.

I got the following error message. It is very strange; it tells me there is no such folder.

[root@h27n2fls301o1037 hey]# cd Opera/

[root@h27n2fls301o1037 Opera]# ls

opera-7.54-20040803.5-shared-qt.i386-en/
opera-7.54-20040803.5-shared-qt.i386-en.tar.gz
opera_7.54-20050131.5-shared-qt_en_sarge_i386.deb

The above 'ls' command shows all the stuff inside the Opera folder.

Then I did the following:

[root@h27n2fls301o1037 Opera]# cd download/
bash: cd: download/: No such file or directory
[root@h27n2fls301o1037 Opera]#

Why it didn't find the folder called 'download' ?

btmiller 03-05-2005 12:58 PM

From the results of your find, your RPM is in .opera/download, not in Opera. Note the leading . (which means the directory is hidden, so it won't show up in ls without the -a flag) and keep in mind the file/directory names in Linux are case sensitive.

Gins 03-05-2005 01:11 PM

I have a hunch that Mandrake doesn't support RPM. Because RPM comes from Red Hat.

I am not sure. I don't know much about those issues.

Gins 03-05-2005 01:18 PM

btmiller

I tried to go into the opera folder. It doesn't work. I did it as a root user. Why is that?

[root@h27n2fls301o1037 hey]# cd opera/
bash: cd: opera/: No such file or directory

[root@h27n2fls301o1037 hey]# cd opera
bash: cd: opera: No such file or directory

[root@h27n2fls301o1037 hey]# cd /opera
bash: cd: /opera: No such file or directory

[root@h27n2fls301o1037 hey]#

Gins 03-05-2005 01:27 PM

Now I found some clues. I must go into the folder called '.opera'. It worked.

Read the following:

[root@h27n2fls301o1037 hey]# cd .opera/
[root@h27n2fls301o1037 .opera]#

[root@h27n2fls301o1037 .opera]# ls
acpo/ download.dat menu/ opera-u.reg urlwarn.dir
adprefs.ini global.dat mouse/ pluginpath.ini userstyle.ini
Beanstalk.Standard images/ opera6.adr search.ini vlink4.dat
cache4/ jswarn.dir opera6.adr.bak sessions/
cookies4.dat keyboard/ opera6.ini skin/
download/ mail/ opera.dir toolbar/


[root@h27n2fls301o1037 .opera]# cd download/
[root@h27n2fls301o1037 download]# ls
wine-20050211-mdk.i586.rpm

It found the downloaded wine program. Afterwards I wrote the following:

[root@h27n2fls301o1037 download]# rpm -ivh wine-20050211-mdk.i586
error: open of wine-20050211-mdk.i586 failed: No such file or directory


[root@h27n2fls301o1037 download]# rpm -ivh 'wine-20050211-mdk.i586'
error: open of wine-20050211-mdk.i586 failed: No such file or directory
[root@h27n2fls301o1037 download]#


Why does it say no file here?

Gins 03-05-2005 01:32 PM

I have succeded thanks to everybody. I take my hat off to everybody who supported me.

Read the following:

[root@h27n2fls301o1037 download]# rpm -ivh wine-20050211-mdk.i586.rpm
Preparing... ########################################### [100%]
package wine-20050211-mdk is already installed
[root@h27n2fls301o1037 download]#

Gins 03-05-2005 01:37 PM

It didn't created an icon on the desktop. How can I find the program?

Gins 03-05-2005 01:54 PM

I can't find the program. It has ĺanded somewhere on my computer. Where is it? I looked at the home folder. Nothing visible there.

I can use the 'find' command to search it. What is the name of it?

XavierP 03-05-2005 04:43 PM

The program is called wine, you install and run Windows programs with:
wine /path/to/program/setup.exe
and run with
wine /path/to/program.exe

Gins 03-06-2005 04:23 AM

Thanks Xavier

I have one more question. Do I have to mount the Windows partition? It is called D:
It has Windows 2000 Professional version.

I just want to copy some important files to the Linux. Then I will format it and install Windows 2000 again. It has some big problems. I have no choice but to reformat.

Could you please tell me whether it is necessary to mount before running wine?


All times are GMT -5. The time now is 06:49 AM.