LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 10-19-2001, 11:42 AM   #1
rdaves@earthlink.net
Member
 
Registered: May 2001
Location: Full-time traveler I live where I am.
Distribution: I use Red Hat V 7.1
Posts: 297

Rep: Reputation: 30
How do I stop linux from probing for HDA and HDB?


When my computer is booting, it performs an IRQ probe for HDA and HDB. I have no HDs attached to the Primary IDE connector. Instead, they are attached to Primary Ultra ATA 100 IDE connector and are identified as HDE and HDF.

So, how do I tell linux not to probe for HDA and HDB?

Following are the messages that I get on bootup. It takes several seconds for this unnecessary probe;
Code:
Oct 18 07:59:15 localhost kernel: hda: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hda: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hda: no response (status = 0x0a), resetting drive
Oct 18 07:59:15 localhost kernel: hda: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hda: no response (status = 0x0a)
Oct 18 07:59:15 localhost kernel: hdb: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hdb: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hdb: no response (status = 0x0a), resetting drive
Oct 18 07:59:15 localhost kernel: hdb: IRQ probe failed (0xffffff78)
Oct 18 07:59:15 localhost kernel: hdb: no response (status = 0x0a)
 
Old 10-19-2001, 10:20 PM   #2
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Try hda=noprobe hdb=noprobe or hda=none hdb=none. The none is supposed to be used when there is no drive connected.

Last edited by linuxcool; 10-20-2001 at 10:27 PM.
 
Old 10-20-2001, 10:39 PM   #3
rdaves@earthlink.net
Member
 
Registered: May 2001
Location: Full-time traveler I live where I am.
Distribution: I use Red Hat V 7.1
Posts: 297

Original Poster
Rep: Reputation: 30
Not sure where these commands go

I am using System Commander menu facility to dual boot my computer. When the menu comes up, and I want to boot linux, I chose "linux", then I get a RedHat window with only one option, "linux" I can click on "linux" or wait three seconds for an automatic boot.

I don't seem to have a place to type either of the commands you suggest.
So I assumed that these commands could be put into my lilo.conf as follows:

Code:
 append="hdd=ide-scsi hdc=ide-scsi hda=noprobe hdb=noprobe"
I have added both of the entries you suggested, but the probe still occurs. The probe happens before the RedHat stuff starts up.

Any ideas?
 
Old 10-21-2001, 09:42 AM   #4
wdingus
Member
 
Registered: Aug 2001
Location: Kingsport, TN
Distribution: RHEL & FC
Posts: 267

Rep: Reputation: 30
You ran /sbin/lilo after making changes to lilo.conf?

On the LILO screen it should have a text prompt to type "linux hda=noprobe" or whatever at the bottom if older RedHat or for newer it will say "Press CTRL-X for text mode" or something similar to that for newer.

To make it permanent though, what you did in lilo.conf should be correct.
 
Old 10-21-2001, 10:36 AM   #5
rdaves@earthlink.net
Member
 
Registered: May 2001
Location: Full-time traveler I live where I am.
Distribution: I use Red Hat V 7.1
Posts: 297

Original Poster
Rep: Reputation: 30
Success!

First of all, I forgot to run lilo after changing lilo.conf.

Also, there is an instruction on the RedHat linux startup screen that says "press control-x for text mode". So, I do have a way to enter the suggested text when lilo starts.

But I booted up, ran lilo and rebooted. And, yippee!, no probe.

Thanks.
 
Old 10-21-2001, 04:48 PM   #6
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
You're welcome.

I did a little more checking and you could probably also use in place of hda=noprobe or hda=none, ide0=noprobe or ide0=none. ' ide0 ' is the primary ide channel. ' ide1 ' is the secondary channel. And so forth. The ' ide0=' argument would prevent linux from probing the entire primary ide channel. ' ide1 ' works on the secondary channel. Since you don't have any drives connected, you could use ' none ' instead of ' noprobe '.

Last edited by linuxcool; 10-21-2001 at 05:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub troubles. Moving linux from hda to hdb Zarneth Linux - General 3 06-29-2005 04:57 PM
dual boot - hda & hdb - both Linux tw001_tw Slackware 8 09-07-2004 07:36 PM
cfdisk hdb instead of hda deceasedcomrade Slackware 1 11-20-2003 09:22 PM
lilo dual boot two linux distros / hda and hdb rioguia Linux - Newbie 2 01-23-2003 12:35 AM
moving the HD from hdb to hda NGraphiX Linux - General 2 10-07-2002 04:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 01:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration